Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My external hard disk always appears in the Unity tool bar.

Right click on the icon does not display any "Unlock from Launcher" option. Only "Eject" option.

enter image description here

So how is it possible to remove the icon of hard disk in Unity ?

Even better: how can this icon never appear in the Unity tool bar ?

Note:

  • Ubuntu version : 12.04
  • Session: gnome-classic
  • Unity tool bar: the Unity tool bar is launched when starting the computer with unity-2d-shell as described in this answer
  • there should be a way to blacklist it, the option to remove an icon from the tool bar is available for any other icons.
share|improve this question
1  
See this question: askubuntu.com/questions/62011/… –  To Do Dec 9 '12 at 17:38
    
The answers in your link does work in may case. The chosen answer is based on an old version of CCSM, an other answer suggest to use MyUnity, I install it but I m not able to launch it, pretty sure because I have a gone-classic session –  Boris Dec 9 '12 at 17:55
    
Finally, I ve been able to launch MyUnity, but my session is running in 2D mode, so all option about the launcher are unavailable. –  Boris Dec 9 '12 at 18:10
    
Blacklisting might be the solution, I m going to follow this answer askubuntu.com/a/195998/32413 ... –  Boris Dec 9 '12 at 18:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.