Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was just wondering if there's a way to set the color of the Unity panel manually, as opposed to having it derived from smooshing all the colors of the wallpaper together. (the launcher on the left side of the screen that comes default in Ubuntu is the Unity Panel, right? If not, please correct me on my terminology.)

The reason I want this is because I have this cool wallpaper I found on DeviantArt, and I used GIMP to make Dawn, Dusk, and Midnight versions of it. Then, I set them with a transition effect, so that the lighting changes over the course of the day. Unfortunately, the Unity Panel turns a sickly sewer green at night (it could also be said to look like radioactive barf.) Either way, I don't like my launcher thingy looking like that.
I'd prefer to stay away from programs that let you customise the Unity Panel (I'm fine with using sudo nano to edit system config files,) but I would if it were the only option.

Here are some screenshots, one with a grey-themed wallpaper, one with lots of red, and the hill at night, (the one that makes the unity panel look like radioactive barf.): http://imgur.com/a/0Gqcd

share|improve this question
add comment

2 Answers 2

The only way I know of to do this is the use CompizConfig Settings Manger. First you'll need to install it:

sudo apt-get install compizconfig-settings-manager

CCSM will now show up in the Dash or can be run from the command line with

ccsm

In the "Desktop" category, you should see an "Ubuntu Unity Plugin" button. Click this and go to the "Experimental" tab. The first option there should be called "Background Color". You can click on the color and pick any color you'd like. The Unity panel should now remain that color regardless of your desktop background.

If you'd ever like to go back to the automatic color selection, click the reset button for the "Background Color" option.

share|improve this answer
    
Okay... For some reason, I can't get a translucent panel when using this. If the opacity of the color is set to anything but 0, then it becomes completely solid. The color of the bar on the top of the screen also messes up. See this: imgur.com/L9t9K –  JamesTheAwesomeDude Dec 9 '12 at 21:11
    
I haven't been able to reproduce what happens with the top bar, but the opacity does behave strangely. I found that even with 255 opacity the panel was still partly translucent. Setting the opacity above 200 even seemed to make the panel more translucent. This may be why this setting is classified as experimental. –  Andrew Johnson Dec 9 '12 at 21:35
    
Lol, your bug was the opposite of mine: my launcher was 100% opaque, yours was always stuck with some translucency. Well, I found out that MyUnity allows you to change the color w/o any transparency issues (it also allows you to change the transparency without problems!) so I went ahead and posted+accepted an answer. –  JamesTheAwesomeDude Jan 4 '13 at 0:38
add comment
up vote 2 down vote accepted

MyUnity perfectly solves this probem.

sudo apt-get update
sudo apt-get install myunity

Then, launch it. The color option will be immediately visible, if not, go to the "Launcher" tab.

The slider to change the launcher's opacity is not broken, and is already set to the default amount.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.