Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

From other questions raised, I read that if Ubuntu Live USB boots in UEFI mode then it should detect Windows 8 during installation. During installation, I only see two options, Erase disk and install Ubuntu and Something else. I don't want to Erase disk and install Ubuntu but Install Ubuntu alongside windows 8. How can I enable the Ubuntu 12.04 Live CD/USB to detect the existing Windows 8? Thanks.

Sorry the latest response.

@Rod here are the screenshots as requested:

Installation type Partition table

@Paddy here's the result from running sudo parted --list:

ubuntu@ubuntu:~$ sudo parted --list
Model: ATA TOSHIBA MQ01ABD1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  473MB   472MB   ntfs         Basic data partition  hidden, diag
 2      473MB   746MB   273MB   fat32        Basic data partition  boot
 3      746MB   880MB   134MB   ntfs         Basic data partition  msftres
 4      880MB   990GB   989GB   ntfs         Basic data partition
 5      990GB   1000GB  10.4GB  ntfs         Basic data partition  hidden, diag


Model: WD 1600BEV External (scsi)
Disk /dev/sdb: 160GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  160GB  160GB  primary  ntfs


Model: TOSHIBA TOSHIBA USB DRV (scsi)
Disk /dev/sdc: 8011MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      4129kB  8011MB  8007MB  primary  fat32        boot, lba

Thanks!

share|improve this question
    
Are you sure that Windows 8 is installed with UEFI? If not, you may need to boot Ubuntu normally. –  Paddy Landau Dec 9 '12 at 16:02
    
@Paddy Well, it's a new laptop and when I called Toshiba service, they mentioned UEFI. The initial issue was that Toshiba qosmio x870 that came with windows 8 wasn't detecting Ubuntu Live CD/USB until I disabled the Secure Boot. Now I'm able to boot to Windows 8 with Secure Boot disabled and also boot the Live USB. The problem is that when attempting to install Ubuntu after trying it, it doesn't detect Windows 8. It shows only two options as explained in the question. Can you please explain what you meant by booting Ubuntu normally? Thanks –  Mighty Dec 9 '12 at 17:15
    
Try the "Something Else" option and report on what it's telling you about your partition table. (You needn't install all the way; I just want to know what partitions the installer is seeing, if any.) A damaged partition table could cause the sort of symptom you're seeing, or it could be something else is going on. –  Rod Smith Dec 10 '12 at 0:07
    
@Mighty: UEFI is pretty new, so there may be some problems. See question 227149. To follow on from @Rod Smith, you could also boot into "Try Ubuntu", open a terminal (press Ctrl+T), and enter the command sudo parted --list. Paste the results here. –  Paddy Landau Dec 10 '12 at 10:05
    
@thakrage I finally decided to Erase disk and install Ubuntu. :) Installing other OS on a VirtualBox. –  Mighty Mar 11 '13 at 23:39
add comment

1 Answer

Mount EFI to /boot/efi but DO NOT FORMAT then after that, mount your other partitions (eg /home /). Install and reboot. You will now boot to Ubuntu so you can configure grub.cfg to be visible and add a Windows option. I have no experience in installing Ubuntu on EFI as I am an Arch user but this should help. EDIT

This will not work if you did not boot Ubuntu from UEFI. To boot DVD/USB in UEFI keep it enabled but disable secure boot option in BIOS. Do all as root sudo -i or su root List all your partitions with cat /proc/partitions Make an efi directory mkdir /boot/efi Mount your EFI partition eg: mount /dev/sdX /boot/efi Install grub-efi apt-get install grub-efi Finally, install grub. Grub will automatically add option to Firmware Boot Manager. grub2-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Ubuntu --recheck --debug

share|improve this answer
    
Hello user119808, thanks for your feedback. I would ask that you update your answer and give a detailed solution that other users can read and try based on your experience that works. For example, rather than say mount your other partitions /home/, you should say, mount /home/ and also indicate if a root user or not in which case it would be sudo mount /home/. Let the user know that this process is done from the terminal. Also you didn't indicate if the process is done from a live cd/usb and how. Thanks –  Mighty May 1 '13 at 16:51
add comment

protected by Community May 14 '13 at 11:20

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.