Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 12.04 few months back. My modem, Tata Photon Plus got connected after a number of unsuccessful trials and I browsed the net successfully.

But since a month, it is not getting connected. Whenever I try to connect, it shows this msg:

CDMA Network
You are registered on the home device

and

Modem Network-Disconnected, you are offline

The network signals are completely ok as I am using the same device in Windows 7. I plug in the modem every time I try to connect it.

Please help me out.

share|improve this question
    
What username and password did you used? –  VedVals Dec 9 '12 at 14:59
add comment

5 Answers 5

please Visit this website :

I got answer from this site.

now it's work on my system

share|improve this answer
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  fossfreedom Dec 12 '12 at 12:23
add comment

Same problem faced. After many hit and trials found a trick that is working for me. I change the port once it gives that problem and restart. Works for me.

share|improve this answer
add comment

I faced the same problem with mts mblaze it often get disconnected while photon + works fine on the same device.

this might help 1. reboot the system before you plug your usb drive(work for me in mblaze). 2.Enter the username and password as "internet" by editing network connection.

share|improve this answer
add comment

The steps for using Tata Photon+ on ubuntu are-

  1. First connect tata photon on any windows machine. Open the device through Windows Explorer. Copy directory Linux and file install_linux from it on to any usb pendrive and then via it copy them into your home directory in Ubuntu. Now connect tata photon+ to ubuntu.

  2. Open terminal and become root user

  3. Change permissions as executable of file install_linux by command chmod 777 install_linux

  4. Run this file(which is a shell script) as ./install_linux

  5. The script will run and then a prompt will appear. Press enter on the prompt.

  6. Follow some on screen instructions on terminal (if any)

  7. After this is complete Photon+ will be installed at path /usr/local/Photon_Plus

  8. Finally fire a command /usr/local/Photon_Plus/MobilePartner

  9. This will pop the Tata Photon startup window same as in Windows through which you can Connect.

    • Help for this is provided in README file in the Linux directory
share|improve this answer
add comment

If you don't want to go through the installation process specified in the other answer, just connect your dongle to a windows machine first and change the setting from "Photon+ mode" to "Hybrid mode". This will allow ubuntu to access the modem.

Once you do that, login to ubuntu and your modem will be detected by the NetworkManager. Proceed with creating a new mobile-broadband connection through a dialog like the one below. Once the connection is created, you will able to use it to connect to internet using your photon+ dongle.

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.