Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need xorg-server version 2:1.9.0.902-1ubuntu3 installed because it contains a fix:

xorg-server (2:1.9.0.902-1ubuntu3) natty; urgency=low

  * Add 207_dga_master_device.patch: Cherrypick from upstream xserver git
    to fix crash with a bluetooth keyboard when using XBMC full screen.
    (LP: #597895)
 -- Bryce Harrington <email address hidden> Thu, 06 Jan 2011 12:17:16 -0800

And I need that for my xbmc to work properly, but on my machine it shows: xorg-server 2:1.9.0-0ubuntu7.1 when I run X -version

Any ideas? I can't find any packages to install and apt-get says it's already the most current version...

share|improve this question
add comment

1 Answer

The easiest way to get the fix is to use the xorg edgers PPA:

https://launchpad.net/~xorg-edgers/+archive/ppa

The PPA is built for testing and for fixing obscure bugs with certain releases. It currently has xorg version 2:1.9.2.901+git20101129 and you may be looking for 902 instead of 901, but try it because it'll get you most of the way there and it's likely it'll be updated anyway.

What ever you do, don't compile yourself. If you feel the urge to DIY, please build some deb packages for yourself instead. More details here:

https://edge.launchpad.net/~xorg-edgers

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.