Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu on my Samsung series 3 laptop (NP305E7A-A02US) with an AMD A6-3420M with Radeon HD 6520g graphics, and I am trying to install the flgrx experimental driver. However, I can not find the experimental driver, and when I use the stable version of that driver, the top bar does not show and the Unity launcher does not show up. On top of that, when I try to install the AMD drivers from the AMD site, it gives me the error One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver. Optionally, run the installer with the --force option to install without the tools. Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended. See /usr/share/ati/fglrx-install.log for more details. I checked the directory and sure enough, it said Supported adapter detected. Check if system has the tools required for installation. fglrx installation requires that the system have kernel headers. /lib/modules/3.5.0-20-generic/build/include/linux/version.h cannot be found on this system. One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver. Optionally, run the installer with --force option to install without the tools. Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended. I have no idea what this is and I need to fix it, as I was accepted into the Steam for Linux beta, and they recommended this amd driver. Any help is greatly appreciated. Thanks so much!

share|improve this question
    
See askubuntu.com/questions/75709/… –  user68186 Dec 9 '12 at 3:16

2 Answers 2

The error indicates that you need to have the kernel headers. Try installing just the kernel headers:

sudo apt-get install linux-headers-generic

and repeat your previous installation steps. If you have a hybrid graphics system (AMD + Intel graphics), the following instructions were quite helpful:

Ubuntu 12.10 AMD/Intel Hybrid Graphics not working

share|improve this answer
    
Thanks. I did that and the installation went great. However, when I installed the AMD driver from the site, Unity is still broken, and the option to switch back to the open-source driver for the time being is greyed out. Also, I do not have Intel/AMD hybrid graphics. Thanks! –  user113539 Dec 9 '12 at 15:50
    
Did you reconfigure the Xorg file with a sudo aticonfig --initial before rebooting? –  bkloppenborg Dec 9 '12 at 21:39
    
No, I did not. It's okay though, I just reverted to 12.04 and everything works fine now. It seemed like this problem is very prevalent in 12.10. –  user113539 Dec 9 '12 at 23:40

I had the same issues but I finally found a way to use AMD drivers while keeping the Unity launcher working.

First in the terminal update your kernel with

   sudo apt-get install linux-headers-3.5.0-17-generic

Next go to the AMD website and download the 12.11 Beta drivers

Download the drivers and place the drive file (.run file) on the desktop

In the terminal run the following:

cd /home/yourname/Desktop (Replace yourname w/ your Ubuntu login username)

Followed by

sudo sh amd-driver-installer-catalyst-12.11-beta11-x86.x86_64.run

The AMD driver/catalyst installer should open, follow the step by step and restart!

Your unity bar should work while you have the latest drivers! WOo!

Also - to remove the watermark (For AMD testing only) simply open the terminal and run

sudo gedit /etc/ati/signature

Then replace "Unsigned" with 9777c589791007f4aeef06c922ad54a2:ae59f5b9572136d99fdd36f0109d358fa643f2bd4a2644d9efbb4fe91a9f6590a145:f612f0b01f2565cd9bd834f8119b309bae11a1ed4a2661c49fdf3fad11986cc4f641f1ba1f2265909a8e34ff1699309bf211a7eb4d7662cd9f8e3faf14986d92f646f1bc

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.