Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't seem to fix or update, upgrade VLC at all; this is what I get when trying to install, I had VLC before, but was not working properly so I uninstalled it; then I tried to install it again to have the full properties. So now I cannot install as I get this message, I have tried everything and have checked with your site for additional info; any suggestions to someone who is new to Ubuntu and Linux altogether?

# Package dependencies cannot be resolved
# This error could be caused by required additional software packages which are  missing or not installable. 
# Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time

# The following packages have unmet dependencies:

vlc:  
Depends: vlc-nox (= 1.1.12-2~oneiric1) but 2.1.0~~git20121022+r2158-0~r88~oneiric1 is to be installed  
Depends: libaa1 (>= 1.4p5) but 1.4p5-38build1 is to be installed  
Depends: libavcodec-extra-53 (>= 4:0.7-1) but 4:0.7.6ubuntu0.11.10.1+medibuntu1 is to be installed  
Depends: libavutil-extra-51 (>= 4:0.7-1) but 4:0.7.6ubuntu0.11.10.1+medibuntu1 is to be installed  
Depends: libc6 (>= 2.8) but 2.13-20ubuntu5.3 is to be installed  
Depends: libfreetype6 (>= 2.2.1) but 2.4.4-2ubuntu1.2 is to be installed  
Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.1-9ubuntu3 is to be installed  
Depends: libqtcore4 (>= 4:4.7.0~beta1) but 4:4.7.4-0ubuntu8.2 is to be installed  
Depends: libqtgui4 (>= 4:4.5.3) but 4:4.7.4-0ubuntu8.2 is to be installed  
Depends: libsdl-image1.2 (>= 1.2.10) but 1.2.10-2.1 is to be installed  
Depends: libsdl1.2debian (>= 1.2.10-1) but 1.2.14-6.1ubuntu4 is to be installed  
Depends: libstdc++6 (>= 4.6) but 4.6.1-9ubuntu3 is to be installed  
Depends: libxcb-xv0 (>= 1.2) but 1.7-3 is to be installed  
Depends: zlib1g (>= 1:1.2.3.3.dfsg) but 1:1.2.3.4.dfsg-3ubuntu3 is to be installed`
share|improve this question
add comment

1 Answer

I've had this happen to me, too. You'll have to open a terminal. The first thing is to check for broken dependencies:

sudo apt-get install -f

If that doesn't work, I would purge vlc and reinstall:

sudo apt-get purge vlc*
sudo aptitude purge $(dpkg -l|grep ^rc|awk '{ print $2 }')
sudo apt-get update
sudo apt-get autoremove
sudo apt-get install vlc

I'm not sure if this will work, but let us know and I can adjust depending on your results.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.