Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using a Quantal AMDx64 install and a XFX Radeon HD5850 video card. I first enabled restricted drivers through additional drivers, but it resulted in breaking Unity and Compiz (I can only see my wallpaper and shortcuts. But the terminal still works and Nautilus too, however, without Close/Maximize/Minimize and slower). Then I uninstalled it and everything went back to normal. Then I installed it via terminal (12.10 version), and the result was the same. Then I downloaded it via ATI's web site (12.11 beta) and installed the .run file using the terminal, but the result was yet again the same. Then I went to the terminal and entered these commands:

aticonfig --help used the command it said it should be used to set the card for the first time aticonfig --initial compiz --replace - It gave me a driver error, the OpenGL doesn't work unity - Same thing

And I also got the "AMD Testing Only" watermark.

Side notes: My Ubuntu is installed on a ext4 partition with 60GB, and I dual boot with Windows 7 (at least for now). My internet is a 50kbps 3G-ish, so downloading even small files is a pain, let alone a video driver. I would rather not reinstall the O.S., it was a herculean task to download everything I had in there, and I have very little free disk space for backups. I'm still new to Ubuntu (I know some basic commands), and I don't know how to debug, so please, be patient XD.

Thanks in advance. If you need any info, just ask (and explain how to get it XD).

UPDATE I just installed the restricted-updates driver too, but the result was the same. Now I found the Xorg.2.log, but the site doesn't let me post it here, so I'll have to ask me to look for specific parts of it.

share|improve this question
    
Look for lines with (EE) in your Xorg.0.log and put them here (update your post). –  Melon Dec 17 '12 at 11:20
    
Try reseting unity with unity-reset(in terminal), maybe a compiz setting is in conflict with the driver.It's just a suggestion. –  adi Mar 14 '13 at 19:50

1 Answer 1

You might need to first completely uninstall fglrx, then install the linux headers

sudo apt-get install linux-headers-generic

Then try to either use fglrx-updates from Additional Drivers or Catalyst 12.11 beta from AMD's site (this won't fix the watermark, though).

share|improve this answer
1  
Ok, so months after the AMD driver finally started to work, but I still need to update the entire system before it and download it through Additional Drivers (normal fglrx, NOT fglrx-update. I downloaded mine through xorg-edgers, too). Just a little tip for those who are still looking for an answer. –  White Apr 16 '13 at 19:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.