Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Wireless doesn’t work on a Broadcom BCM4312

I installed Ubuntu 12.10 amd64 on a macbook 3,1. Wireless was working until I ran a "software update", and now I am without wireless.

I have an internal Broadcom Network Adaptor (BCM4321).

share|improve this question
add comment

marked as duplicate by Tom Brossman, fabricator4, Ringtail, Jorge Castro, Uri Herrera Dec 9 '12 at 8:50

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

Your problem looks similar to mine, and I think the new kernel and broadcom drivers are the connection. I ran

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

which I found here - Wireless does not work anymore after software update with Ubuntu 12.10 on a Dell Latitude E6230

and it worked for me on my Acer Laptop.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.