Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am following the steps in https://wiki.ubuntu.com/PbuilderHowto to build a package, and I get stuck with unmet dependencies in apt-get. The command that I use to build are:

$ sudo pbuilder update --distribution precise --override-config
$ pdebuild

This is the resulting error from the *build output file:

I: Current time: Sat Dec 8 16:24:21 UTC 2012 I: pbuilder-time-stamp: 1354983861 I: Building the build Environment I: extracting base tarball [/var/cache/pbuilder/base.tgz] I: creating local configuration I: copying local configuration I: mounting /proc filesystem I: mounting /dev/pts filesystem I: Mounting /var/cache/pbuilder/ccache I: policy-rc.d already exists I: Obtaining the cached apt archive contents I: Setting up ccache I: Installing the build-deps This package is uninstallable Dependency is not satisfiable: mpi-default-bin

E: pbuilder-satisfydepends failed. I: Copying back the cached apt archive contents I: unmounting /var/cache/pbuilder/ccache filesystem I: unmounting dev/pts filesystem I: unmounting proc filesystem I: cleaning the build env I: removing directory /var/cache/pbuilder/build//2422 and its subdirectories

I do have mpi-default-bin and the other pre-requisite package installed:

$ aptitude show mpi-default-bin Package: mpi-default-bin State: installed Automatically installed: no Version: 1.0.1 Priority: extra

Any idea what could be missing and how I can force pbuilder to install the required packages in the chrooted build environment?

share|improve this question
    
Sounds like your pbuilder doesn't have universe enabled. Does it? –  tumbleweed Dec 10 '12 at 19:27
    
How can I enable universe support for pbuilder? I have universe and multiverse on the build machine itself at /etc/apt/sources.list - I don't think this is the setting that pbuilder is using –  hanxue Dec 11 '12 at 11:48
    
I have added this to ~/.pbuilderrc COMPONENTS="main restricted universe multiverse" Still getting this result dpkg-checkbuilddeps: Unmet build dependencies: mpi-default-bin dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting. dpkg-buildpackage: warning: (Use -d flag to override.) debuild: fatal error at line 1350: dpkg-buildpackage -rfakeroot -D -us -uc --source-option=--include-binaries --source-option=-isession failed –  hanxue Dec 11 '12 at 11:59
    
You need to update your tarball after doing that, and be sure that it downloads universe package lists. –  tumbleweed Dec 12 '12 at 8:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.