Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As the title says, I'm having trouble with a very noisy audio input device - the internal mic or any plugged in mics.

So far I've narrowed it down to an problem in ALSA since my debug info is showing a lot of "null" values. Can anyone help?

Debug Info: http://www.alsa-project.org/db/?f=e0c6fb7e10624bf7691aa2b405cf0d3968e56c63

Exert from the debug:

model : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
share|improve this question
add comment

1 Answer

Not a real answer, but some debug help. I would disable pulseaudio while testing (put autospawn to /etc/pulse/client.conf and pulseaudio -k). Then make test recording using

arecord -f dat -r 44100 -D hw:0,0 test.wav

Play back with aplay. Then play around with the sample rate (-r) and with module options in /etc/modprobe.d/alsa-base.conf (reload using sudo /sbin/alsa force-reload). The options are position_fix, model and enable_msi. I for example got lucky by setting the model to dell (which I don't think I got), position_fix to 2 and enable_msi to 1. No real science behind this.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.