Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I'm trying to access the internet on my laptop using wireless tethering option on my android phone. I'm able to make DNS queries and also ping my Gateway but i'm neither able to ping other sites like nor access internet. Here is the output of some commands that might help in resolving the issue,

itachi@itachi-laptop:~$ uname -a

Linux itachi-laptop 3.2.0-34-generic #53-Ubuntu SMP Thu Nov 15 10:49:02 UTC 2012 i686 i686 i386 GNU/Linux

itachi@itachi-laptop:~$ cat /etc/lsb-release


itachi@itachi-laptop:~$ route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface         UG    0      0        0 wlan0     U     1000   0        0 wlan0   U     2      0        0 wlan0

itachi@itachi-laptop:~$ ping

PING ( 56(84) bytes of data.

64 bytes from icmp_req=1 ttl=64 time=1.96 ms

64 bytes from icmp_req=2 ttl=64 time=1.99 ms

64 bytes from icmp_req=3 ttl=64 time=2.00 ms
--- ping statistics ---

itachi@itachi-laptop:~$ ping

PING ( 56(84) bytes of data.

--- ping statistics ---

40 packets transmitted, 0 received, 100% packet loss, time 39313ms

itachi@itachi-laptop:~$ lspci -nnk | grep -iA2 net

0c:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection [8086:4229] (rev 61)
    Subsystem: Intel Corporation Device [8086:1120]
    Kernel driver in use: iwl4965

itachi@itachi-laptop:~$ ifconfig wlan0

wlan0     Link encap:Ethernet  HWaddr 00:21:5c:6a:3d:11  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::221:5cff:fe6a:3d11/64 Scope:Link
          RX packets:439 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3994 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:64469 (64.4 KB)  TX bytes:427656 (427.6 KB)

I'm able to access the internet when I directly connect via a usb-dongle and that is why i'm posting this question. When I try using wifi tethering though, I'm unable to ping nor access internet. Any help to resolve this issue would be much appreciated. Thanks.

share|improve this question

2 Answers 2

What version of Android are you using?

Being able to ping your gateway just says it can talk to your phone - which implies the issue is with the phone's forwarding of packets. The reference to may be a cached DNS entry, not live. I'm currently trying something similar with bluetooth, and seeing reports of JellyBean's tethering being crippled.

share|improve this answer

look if this file exists




if one is missing. Do this:

sudo dpkg-reconfigure resolvconf

For the first question answer: yes

For the second question answer: no (no = do not append old configuration)


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.