Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After starting Totem in Ubuntu 12.10 (playing an .MTS file), it starts out playing just fine, but after about 3 seconds the sound goes away. No clue at all what is happening. .MPG files play just fine.

The videos play just fine, with sound, in VLC.

EDIT: Pausing the video and then starting again brings sound back for about one second, and then the sound fades again.

share|improve this question
Do you have ubuntu-restricted-extras installed? – Seth Dec 11 '12 at 16:42
I do, of course. In fact, today something funny happened: I reverted back to Ubuntu 12.04 (12.10 was really giving me too much trouble). In 12.04 Totem had sound, just fine, as well as VLC. On the other hand, gxine experienced the same problem as Totem on 12.10 (i.e. sound was fading after a few seconds); however, on 12.10, gxine played fine! I think something funny is happening with audio channels. Somehow after playing the video for a few seconds, I guess some channels are muted (but pausing and starting the video again, the sound plays for two seconds again, then fades). – William Dec 13 '12 at 6:08
Also, in 12.04, Totem videos are jagged, but gxine and VLC play them smoothly (so that Totem's behavior can't be due to driver issues). However, on 12.10, minus the sound problem, Totem had even better performance on HD videos than VLC or gxine (deinterlacing worked beautifully). – William Dec 13 '12 at 6:09
up vote 0 down vote accepted

Apparently this is due to Totem not using the correct driver/hardware (somehow that changes without notice). By setting the correct channel in the control center, everything works fine. This is strange, since youtube videos would use the correct channel, while Totem would switch to an incorrect one.

share|improve this answer
I seem to be having the same problem, could you elaborate on the fix? – Brian Jun 30 '15 at 10:33
@Brian You can navigate to 'audio' in the control center and play with the options there. – William Oct 27 '15 at 1:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.