Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So i go to system settings in Ubuntu 12.10 and i want to install my drivers but under the Additional Drivers, My LAN doesnt work, Doesnt even pick up that im plugged in threw Ethernet cord. I have a GTX 670M with 3Gb GDDR5 for a video card and would like to use that. Just need help, pretty new to Ubuntu.


Ok when i looked at that other question i did the sudo lspce -nn and this is what i got



madmike@Mike-GT70:~$ sudo lspci -nn 
00:00.0 Host bridge [0600]: Intel Corporation 3rd Gen Core processor DRAM Controller [8086:0154] (rev 09)
00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port [8086:0151] (rev 09)
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04)
00:16.0 Communication controller [0780]: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 [8086:1e3a] (rev 04)
00:1a.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 [8086:1e2d] (rev 04)
00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
00:1c.0 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 [8086:1e10] (rev c4)
00:1c.2 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 [8086:1e14] (rev c4)
00:1c.4 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 5 [8086:1e18] (rev c4)
00:1d.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 [8086:1e26] (rev 04)
00:1f.0 ISA bridge [0601]: Intel Corporation HM77 Express Chipset LPC Controller [8086:1e57] (rev 04)
00:1f.2 SATA controller [0106]: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] [8086:1e03] (rev 04)
00:1f.3 SMBus [0c05]: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller [8086:1e22] (rev 04)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:1213] (rev ff)
02:00.0 Ethernet controller [0200]: Atheros Communications Inc. Device [1969:e091] (rev 13)
03:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 2230 [8086:0887] (rev c4)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader [10ec:5209] (rev 01)
04:00.1 SD Host controller [0805]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader [10ec:5209] (rev 01)

Let me know if anything else is needed.

share|improve this question
add comment

3 Answers

Your Atheros card does not have a driver installed. From the Hardware ID I got from lspci output, I am assuming that you have an Atheros Bigfoot Killer E2200 Ethernet card and your laptop seems to be the MSI Global GT70 0NC (Nice!) gaming laptop. You need to install the compat-wireless driver. If you have Internet access on the machine, try following the steps mentioned here:

http://ubuntuforums.org/showthread.php?t=2008332

This should help you install the driver and then you can plug your LAN cable into the port. I don't think that this is a Network-Manager problem.

Hope that helps you! :-)

P.S.: Make sure you use "eth0" and not "etho".

share|improve this answer
    
even when i did eth0 this is what i got madmike@Mike-GT70:~$ ifup eth0 ifup: failed to open statefile /run/network/ifstate: Permission denied madmike@Mike-GT70:~$ sudo ifup eth0 [sudo] password for madmike: Ignoring unknown interface eth0=eth0. –  madmike59 Dec 8 '12 at 7:00
    
Also when i try to do the <tar -xvf /path/to/compat-wireless-2012-05-10-p.tar.bz2> Command it just comes up with an error so idk how to get that to work out. –  madmike59 Dec 8 '12 at 7:16
    
Well, you need to modify the "/path/to/compat-wireless-2012-05-10-p.tar.bz2" to the actual path to the compat-wireless archive. –  gmjain Dec 15 '12 at 6:14
add comment

There is problem with your Network Manager. You have to reinstall it.

Run Following Command in Terminal

sudo apt-get install network-manager*
share|improve this answer
    
This is what i get when i try ifup etho ********* madmike@Mike-GT70:~$ ifup etho ifup: failed to open statefile /run/network/ifstate: Permission denied madmike@Mike-GT70:~$ sudo ifup etho Ignoring unknown interface etho=etho. madmike@Mike-GT70:~$ –  madmike59 Dec 8 '12 at 3:27
    
Hey madmike59 which Ubuntu version and (32 bit or 64 bit) you are using ? –  K.K Patel Dec 8 '12 at 3:32
    
I am using the 64 bit 12.10 –  madmike59 Dec 8 '12 at 6:57
add comment

I assume that your laptop has an Intel HD 4000/3000 right (optimus)? if so, don't install the drivers under additional drivers, instead, install bumblebee, so you can enable nvidia optimus on ubuntu.

Cheers

share|improve this answer
    
I installed Bumblebee, unsure on how to set it up or if it just runs automatically? –  madmike59 Dec 8 '12 at 8:01
    
The Intel driver is the default one, if you wat to run an app with the nvidia driver use 'optirun <command>' –  Daniel Rivas Dec 8 '12 at 14:40
    
Alright now i have a little bit of a problem as far as i can see, madmike@Mike-GT70:~$ optirun --config FILE [ 485.790527] [WARN]Could not open configuration file: FILE [ 485.790597] [WARN]Using default configuration [ 485.985595] [ERROR]Missing argument: application to run Try optirun --help' for more information. madmike@Mike-GT70:~$ ``optirun run [ 568.055361] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to assign any connected display devices to X screen 0 [ 568.055422] [ERROR]Aborting because fallback start is disabled. madmike@Mike-GT70:~$` –  madmike59 Dec 8 '12 at 19:11
    
Try to open a new question about this. I'll help if I can. –  Daniel Rivas Dec 9 '12 at 4:00
    
Open a new question about not being able to run the optirun command? –  madmike59 Dec 10 '12 at 19:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.