Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm doing an upgrade with sudo apt-get upgrade

After I press Enter:

do you want to continue [y/n]? y
dedconf: apt-extracttemplates failed:No such file or directory
extracting templates from package: 100%
dpkg:error:parsing file '/var/lib/dpkg/status' near line 1146 package 'python-minimal'
'break' field, invalid package name 'python-de~': Character '~' not allowed (only letters,digits and character '-+._')
E:sub-process /usr/bin/dpkg returned an error code (2)

how to fix or edit this ???

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

It looks like there is a typo in the Python post-installation script. This may have been caused by an Internet error of some kind...

Try this:
(CTRL-ALT-T for the Terminal)

sudo apt-get purge python-minimal
sudo apt-get update
sudo apt-get install python-minimal
sudo apt-get upgrade

If that doesn't work, then try using Aptitude instead of Apt-Get.

If that doesn't work, comment and tell me what's going wrong.

share|improve this answer
    
i did but now im getting this one dpkg:error: parsing file ' /var/lib/dpkg/available' near line 13package 'python-pkg-resources': –  elvisvite Dec 9 '12 at 20:25
    
@elvisvite Did that happen during the uninstall, the reinstall, or during the upgrade? Also, did this occur while using apt-get or aptitude? –  JamesTheAwesomeDude Dec 9 '12 at 20:53
    
igot frustraded and re instaled ubuntu server .. im at the point in the cmd line sudo apt-get update .. done sudo apt-get upgrade .. done sudo apt-get install linux-image-server linux-headders-server linux-souce Note: power source when out turn server on and try to do the previous comand and got this message The following package have unmet dependecies: Linux-source : depends :linux-sorce-3.5.0 but it is not going to be installed E:Unmet dependecies try 'apt-get -f install' with no packages ( or specify a solucion) So i try sudo apt-get -f install –  elvisvite Dec 10 '12 at 0:09
    
answer Yes to question and got this error dpkg: error: parsing file '/var/lib/dpkg/available' near line 13 package 'python-pkg-resources': 'confilcts' field syntax error after reference to package 'python2.3-setuptools' E:sub-process /usr/bin/dpkg returned an error code (2) –  elvisvite Dec 10 '12 at 0:11
    
@elvisvite Eep. So.. the power failed while it was doing an update? That is very, very bad. I'd recommend maybe reinstalling again. It looks like the power outage caused the postinstall script to be fractured. This is very weird, and I have never seen something like this before. Perhaps you should file a bug report for Python. It looks like they may have actually had a typo when they were making the package. –  JamesTheAwesomeDude Dec 10 '12 at 4:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.