Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just right clicked on the DVD icon in the Unity Launcher in order to eject it, but instead of hitting the 'Eject' button, I missed and hit the 'Unlock from Launchpad' option instead.

How do I go about ejecting the disk from the drive now that the Launcher option is missing?

share|improve this question

2 Answers 2

up vote 7 down vote accepted

In order to eject a disk from the drive, whether it's a CD or a DVD, open a terminal and simply execute the eject command.

share|improve this answer
    
Does the icon come back next time you insert a disc? –  Tom Brossman Dec 7 '12 at 23:21
2  
The icon does not actually come back for that particular disk. A similar one will appear, at a lower resolution and without the eject option, and the full one will appear when you insert a new disk. I'm not sure how to undo this - I'm still looking into that. –  Chris Wilson Dec 7 '12 at 23:28
1  
I think you need too add the device after the eject command, like eject /dev/sr0 --- It seems the default symlink /dev/dvd is not created anymore by default, and "eject" only works for /dev/dvd when entered without parameters –  marto Dec 7 '12 at 23:43

To open the CD drive / eject the CD: Open Terminal ctrl + alt + t, and type eject To close the tray, type eject -t And to toggle (if open, close and if closed, open) type eject -T

All these commands can be typed into the run dialogue (alt + F2)

For more options, type eject -h into Terminal.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.