Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, I have a dlink 655 whose network is suddenly not showing up in ubuntu? I have just returned from a week of travelling (during which I used plenty of wifi on ubuntu), and on returning home, both win 7 (same computer) and phone can see the network just fine, and ubuntu can see 5 other networks, but my own is gone? I have of coursed tried restarting the router, to no avail. Right now I'm on one of the other networks, which works fine (but is of course pretty unsatisfactory). The network is not hidden.

I'm guessing some driver update in the past week (like a good boy I of course install all suggested updates) has messed something up? Any ideas for what to do?

share|improve this question

closed as off-topic by Jorge Castro, Eric Carvalho, bain, Lekensteyn, Sneetsher Jul 1 at 12:17

This question appears to be off-topic. The users who voted to close gave these specific reasons:

If this question can be reworded to fit the rules in the help center, please edit the question.

    
Its not hidden network is it? –  Seth Dec 7 '12 at 19:44
2  
nope, don't even know how to make it that. I actually tried using "connect to hidden network" and picking it from the list of known networks, but that had no effect. –  Kaare Mikkelsen Dec 7 '12 at 19:52
1  
Please run sudo iwlist wlan0 scan in a terminal. See if you can locate your 'Cell' in the list. If it does, edit and update your question with this complete entry. Also, please provide the output of dmesg | grep cfg80211 and the channel your AP is active on (preferably check this on another client device such as your mobile using a WiFi scanner app). Also log in to your Wireless AP and verify the 'regulatory domain' setting (location). –  gertvdijk Jan 4 '13 at 14:40
    
Try "connect using hidden network" and type in the SSID, password, and encryption type of your network. I would have put this in as a comment, but I am unable to do so. –  nick Jan 4 '13 at 19:31

3 Answers 3

I'm suspecting that your Wireless Access Point is set to 'Auto' on the channel selection and it has decided to hop onto another channel on which your Ubuntu machine thinks it is not allowed to talk on. Alternatively, this might be an issue regarding the dual-band nature of some devices.

Some possible causes I can think of with their relevant fix:

  • Check the 'regulatory domain' or 'Location' setting in your Access Point configuration. In OpenWRT this would look like this:

    enter image description here

    The location set here may be wrong and that will result in using radio channels (frequencies) not allowed in your country. E.g. In Japan, 2.4 GHz band has 3 more available channels compared to the US.

    Similarly, check the same for your Ubuntu machine, e.g. check whether dmesg | grep cfg80211 gives some output that sounds sane to you.

  • Your AP has been updated with a new firmware automatically. Some ISP-provided devices appear to update themselves as being part of a provisioning system. Try to see whether an update has been performed lately.

  • Your AP could be featuring two independent radios (dual band - 2.4GHz and 5GHz) and having one of them in a crashed state. Dual-band capable client devices may be able to see it, but if one of them isn't, then it might not see it. Try rebooting the device.

share|improve this answer

I suggest you to check if your Linux "sees" your network card first. Then, we'll be able to really confirm if it's a driver issue as you seem to assume. What gives the following commands :

cat /etc/network/interfaces

iwconfig

ifconfig
share|improve this answer

change modem channel above 11 I did it is OK now

share|improve this answer
1  
This may have have fixed it in your case, but it might not fix it for everyone. Which wireless channel to use depends highly on wifi interference, which means 11 won't always be a good channel number. –  Flimm Jan 4 '13 at 14:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.