Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded screem(web development environment) and tried to compile it, but after running the ./configure command i get this error.

checking for SCREEM... configure: error: Package requirements (         gtk+-2.0 >= 2.6.0                       glib-2.0 >= 2.6.0                       libgnome-2.0 >= 2.2.0                       libgnomeui-2.0 >= 2.6.0     libxml-2.0 >= 2.4.3                     libglade-2.0 >= 2.3.0                       gconf-2.0 >= 2.2.0gnome-vfs-2.0 >= 2.8.3                        gdk-pixbuf-2.0 >= 2.2.0                     gthread-2.0 >= 2.2.0                        libgtkhtml-2.0 >= 2.2.0                     gmodule-2.0 >= 2.2.0            libgnomeprint-2.2 >= 2.2.0                  libgnomeprintui-2.2 >= 2.2.0                    gtksourceview-1.0 >= 1.1.90                     libstartup-notification-1.0                                     libgnome-menu >= 2.9.2      ) were not met:

No package 'libgtkhtml-2.0' found
No package 'libgnomeprint-2.2' found
No package 'libgnomeprintui-2.2' found
No package 'gtksourceview-1.0' found
No package 'libgnome-menu' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables SCREEM_CFLAGS
and SCREEM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

i also tried to find the missing packages via sudo apt-get cache search but no luck whit the exception of libgnome-menu

how do i install screem in Ubuntu 12.10(amd64)

share|improve this question
up vote 2 down vote accepted

Screem was in the repositories for Hardy (8.04 LTS), as this Launchpad page shows, but that was around five years ago. The Ubuntu packages page contains details about it, but the problem in either installing or compiling lies in that it requires very old dependencies that are not compatible with the current 12.10 packages.

The package you mention, 'libgtkhtml-2.0' was in the repositories for Hardy with the accompanying -dev files necessary for compilation, as were most of the other necessary dependencies, but they can't be installed to the system on 12.10 without causing a lot of problems.

Unfortunately, there hasn't been much active development of the project for a long while, going by the mailing-lists and the code commits, although someone did try compiling recently (2011) and the answer noted on the mailing-lists might give you some help, as it points to a more recent version of the project. However, I think the same problem with dependencies will be present.

share|improve this answer
True! 'libgtkhtml-2.0' 'gdl-1.0' and 'libgnome-menu' not found. to bad, i also couldn't find the dependencies in :( I'll accept your answer! – blade19899 Dec 7 '12 at 19:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.