Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

System: Xubuntu 12.10 x86

I installed the Ati drivers using the Software Center, everything apparently whent fine (no error messages).

After rebooting the system i get a black screen. The system responds to input (if i press the power down button it closes gracefully) but is completely unusable. From the boot menu i can decide to load the root terminal, but i have no idea of what to do in order to remove the drivers.

Following some guides i looked for:

  • the Xorg.conf file in /etc/X11
  • /usr/share/fglrx/fglrx-uninstall.sh
  • /usr/share/ati/fglrx-uninstall.sh

But they were all missing. What steps can i take?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

This is a known problem with ATI drivers on Ubuntu 12.10 (see https://bugs.launchpad.net/fglrx/+bug/1068661/+index?comments=all). I got my hybrid graphics system working by following the instructions below:

Ubuntu 12.10 AMD/Intel Hybrid Graphics not working

If you don't want to compile drivers, installing the xserver-xorg-video-intel and one of the fglrx packages from this PPA should work:

https://launchpad.net/~andrikos/+archive/ppa/+packages?field.name_filter=&field.status_filter=published&field.series_filter=quantal

share|improve this answer
add comment

I found the solution: i had to enable networking and then use:

sudo apt-get remove fglrx*

This seemed to fix things up.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.