Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just updated to ubuntu 12.04 on my Dell laptop xps 15z.

The trouble is that I hear a slight ticking sound every 3rd second, probably from a fan. This is a new issue in this ubuntu version.

I use the recommended boot options for grub, i.e. acpi_backlight=vendor, but I do not use any acpi=off or acpi=noirq.

Is there a way to fix this issue from ubuntu, by maybe controlling the fans somehow?

EDIT: Notice, the sound goes away as the fan speeds up, (when doing calculations or such), so it is really a fan issue.

EDIT2: I have located the issue: If I use conky 1.9, together with the command execpi for a python application, then the sound appears, and the noise syncs with the update interval for conky (NOT for the update interval for execpi!). The noise seems to be proportional to the complexity of the drawing that is needed. This is very strange, as this issue was not in the prev. version of conky I used.

The solution was to increase the update interval for conky from 0.5 to 3, i.e. update every 3rd second instead of twice a second.

share|improve this question
    
If you turn off acpi support, You might see a drastic decrease in battery life. So make sure it's the fan and it's because the OS is messing with the fan. –  SiddharthaRT Dec 10 '12 at 9:59
    
Yes, so I do not intend to turn of acpi, and yes, it is the OS. My question is, how do I convince my OS to work the fan properly? –  Per Alexandersson Dec 10 '12 at 10:09
    
This question clearly describes a bug (and is even tagged 'ubuntu-bug') and so is off-topic for this site. I hope you get it sorted out as it sounds frustrating, but I am going to vote to close it. –  Tom Brossman Dec 13 '12 at 9:01
    
@TomBrossman Ok, as I have solved the issue. However, this is no longer a bug in ubunu, but rather an issue with conky, it seems. Feel free to close. –  Per Alexandersson Dec 13 '12 at 9:08

2 Answers 2

up vote 2 down vote accepted
+50

I have the exact same laptop, and when I tried messing around with acpi=off and the likes, it did cause the fans and power management to bork.

I simply added noapic to the end of the startup line instead, and everything has been working like a dream for the last 9+ months.

One is ACPI (Advanced Configuration and Power Interface) and the other APIC (Advanced Programmable Interrupt Controllers).

share|improve this answer
    
With 12.04 i guess? –  Per Alexandersson Dec 12 '12 at 20:21
    
Yep, worked fine on 11.10, 12.04 and 12.10. Just try it, remove all the flags you added and just add this one. –  md_5 Dec 12 '12 at 22:19
    
Ok, that flag worked, but didn't solve the issue, which turned out to be something completely different than boot options. –  Per Alexandersson Dec 13 '12 at 9:09
    
Care to elaborate on the answer then if you solved it, so others can benefit? –  md_5 Dec 13 '12 at 9:44
    
Sure, added to the end of the question. This is a fix, and not really a satisfactory solution really. –  Per Alexandersson Dec 13 '12 at 10:51

That seems more like something in case than an OS problem, but I presume you've checked that.

They seem to explain fan control here,

Hope this helps.

Disclaimer: I don't think this will fix the situation and all changes should be done at your own risk.

share|improve this answer
    
Well, this is a laptop, and coincidentally, the sound started the same instance as I rebooted with new OS version, with acpi=noirq option. Never had any trouble before. Seems a bit overkill to manually mess with the fan, is this something temporary with the latest kernel maybe? –  Per Alexandersson Dec 10 '12 at 21:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.