Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My computer currently has Fedora, Ubuntu, and Windows installed.

I just updated Ubuntu 12.04, and on restarting, the Fedora entry was gone from GRUB. Ubuntu and Windows remained, though.

I have looked at these threads:

However, I cannot figure out how to mount the drive as suggested. It does not appear in the list on the left side of nautilus as shown in the links above.

no fedora :(

I also tried running the following as suggested above:

sudo grub-install /dev/sdX
sudo update-grub

But this gave scary errors:

/usr/sbin/grub-setup: warn: Attempting to install GRUB to a partitionless disk or to a partition. This is a BAD idea.. /usr/sbin/grub-setup: warn: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged.. /usr/sbin/grub-setup: error: will not proceed with blocklists.

The highlighted drive below is where Fedora lives.

enter image description here

Thanks for any help reversing Ubuntu's decision to delete this from GRUB.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

lvm2 support is not provided by default, you have to install it.

sudo apt-get install lvm2

You should then update grub. Since it will now be able to read the lvm2 partition, it should find Fedora and insert it into the grub menu:

sudo update-grub
share|improve this answer
    
Thank you so much. This is exactly what I needed. –  Kevin Dec 7 '12 at 19:23
    
I've added 'sudo' to the update grub command. I think it's required - but I guess you worked that out. –  fabricator4 Dec 7 '12 at 20:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.