Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Have 30 workstations all running nicely on LTSP, each running ubuntu. Bought 5 Epson V33 scanners, which of course worked fine on local ubuntu installs.

When these clients are running through LTSP the scanners are not detected.

Can anyone lend a hand with this? or give any ideas?

USB flash drives, keyboards , mice etc all come through nicely .

Thanks in advance

share|improve this question

2 Answers 2

I'm having the same problem with an Epson GT-1500 and I've found a solution which works, although not the best solution.

I had to install special epson drivers for my scanner into my chroot area for the clients (Refer:

Downloaded my drivers, copied them into my chroot section and installed with the following commands:

sudo apt-get install xsltproc
sudo dpkg -i iscan*

Once I had that installed I had to rebuild my ltsp image, reboot the client, then once the client was up I had to replug the scanner in. Then I could start simple scan locally and it would work.

 ltsp-localapp simple-scan

Make sure you scanner is coming up on the client

 ltsp-localapp xterm

Then within xterm


You should see your scanner in here.

share|improve this answer

Here's a more detailed procedure that worked for me.

If, after you connect and switch on your scanner, you get the following output from this command,

sudo scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

but this command finds your scanner,

sudo sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
found USB scanner (vendor=0x04b8 [EPSON], product=0x0133 [EPSON Scanner] ...
  # Your USB scanner was (probably) detected. It may or may not be supported by

then you need to install Espon drivers.

Visit this page

and enter GT-1500 for the product name, and Linux for the Operating Sytstem.

Eventually, you will need to download these packages from two separate download pages


Next, install the standard Ubuntu package xsltproc followed by the three pages you have just downloaded

sudo apt-get install xsltproc
sudo dpkg -i iscan*

Afterwards, when scanimage should give you the following output

scanimage -L

device `epkowa:interpreter:002:004' is a Epson GT-1500 flatbed scanner

At this point, I could scan using simple-scan.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.