Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This error keeps showing up. I can't update through the little red circle caution symbol and when I open the software center it stalls and then shuts down.

I tried to do the sudo apt-get install -f thing, but that just said "could not get lock /var/lib/dpkg/lock - open"

What does this all mean? If anyone can help, please use new-user-friendly words and be descriptive.

share|improve this question

1 Answer 1

I have linux-headers-3.5.0-19 in my default package list itself, I don't need to add any additional ppas.

What I understand from your description is that there are broken dependencies on your system. You can try completely removing the packages for which there are conflicts. If it works, then try and reinstall them once again.

The second issue happened probably because you had Synaptic open, and you tried sudo apt-get install -f from the terminal. Is this right?

share|improve this answer
    
I eventually just reinstalled the os. I had only had it up and runing for a our before I found this problem so I thought this wouldn't hurt. IT WORKED! Everything is now working perfectly! I now updated everything, and I have downloaded several things in the Ubuntu software center –  DustinCGuest Dec 8 '12 at 16:18
    
Nice that you got it working. –  Swarnendu Biswas Dec 8 '12 at 20:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.