Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question is from a supernewby -- not with computing, just with Ubuntu, which I installed today.

My only problem -- so far -- is trying to open folders under "Browse Network" in the file manager. At least I guess it's the file manager, though nowhere do you find those words. You get to "Browse Network" by clicking the "Home Folder."

My network printer and "Windows Network" pop up soon enough, but double-clicking "Windows Network" may get to my local network, called "localan," or it may claim a timeout after about 100 seconds. If it does open localan, it shows the two Windows and a Debian machine on that network. Trying to open one of them is the most problematic. Oddly enough, after many timeout reports, suddenly the selected machine will open. At least it has once in an afternoon of trying. Once it opens, files in its folders are readily accessible.

The hardware can't be the problem. Yesterday I was running Windows Vista on it. Local network access was slick as a breeze and not the reason I abandoned Windows.

Typically after a minute or so, trying to open "localan," I get the following notification:

"Sorry, could not display all the contents of "Windows shares on localan": DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."

and nothing else. Clicking "localan" again gets the same timeout and message, although once it did return the list of machines on localan.

Note that I am submitting this question from the same machine, using the same hardware and software, so it can't be the Ethernet adapter. Curious that this is an intermittent problem, which in my experience is rare in software. I can't believe that other users would tolerate it. Does anyone have a suggestion?

Thanks for your attention.

--Robert Smith

share|improve this question

1 Answer 1

I can't believe how this worked out!

Finally, after ~12 hours of searching, I learned how to set a static IP for my machine. To may amazement, doing so completely fixed the problem! Now all LAN access was as speedy as it had been under Vista. By the way, the magic trick in setting a static IP turns out to be hitting Enter after each IP you supply under the Network Manager (accessed by clicking that up-down arrow on the top bar). If you miss even one, you can't save your entries.

However ... A new and related problem arose the next time I booted Ubuntu. It seems one always does! I'll describe this as a new question, entitled, "Gateway IP Returns to Zero."

--Robert Smith

share|improve this answer
    
you can click TAB to fill in each IP (address, netmask, & gateway) –  mchid Aug 2 at 3:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.