Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

What's the best way to run a RDP Server on Ubuntu 12.10?

I'd like to run an RDP server on my Desktop running Ubuntu 12.10 and be able to login from another 12.10 machine using the remote login feature at the login screen.

I've installed xrdp but it doesn't seem to work with unity-3d any ideas?

share|improve this question
    
possible duplicate of What free Remote Desktop (server) solutions are there? –  kamil Feb 10 at 9:50

4 Answers 4

up vote 10 down vote accepted

fyi... xrdp by itself uses VNC on the remote desktop/server to really take advantage of xrdp you also need x11rdp which is often is not provided in the software center etc.

I've found and used the following scarygliders tool that automatically downloads & builds the latest/greatest xrdp and x11rdp on your machine and intalls it for you. It takes a while because of the complexities of building the x11rdp but it has always worked for me.

Then.. with that done.. look into installing guacamole

scaryglider's site: http://scarygliders.net/2012/05/23/the-scarygliders-x11rdp-o-matic-and-rdpsesconfig-hotness-upon-hotness/

guacamole site: http://guac-dev.org/

with guacamole installed and with xrdp/x11rdp... all you need for remote desktop on your client is a HTML5 capable web browser.

This works very well together and the HTML5 browser doesn't require any plugins for the remote desktop.

share|improve this answer
    
This is good, it has a --justdoit option which takes care of the entire install. It also lets you configure xrdp very easily and allows you to select the interface (Gnome, KDE, XFCE, etc.) and installs it if it's not already available. Good solution to the issue with unity 3d for now. –  D4nC00per Feb 1 '13 at 18:04

I had this same problem this morning; attempting to install on an EC2 Ubuntu 12.10 instance. I solved it thusly...

After installing gnome and xrdp, install gnome-session-fallback (instead of 2d or 3d)

sudo apt-get install gnome-session-fallback

Then update .xession...

pico .xsession

Add the this line to .xession (remove others)...

gnome-session --session=gnome-fallback

Exit pico by hitting Ctrl+X and hit Y to save when prompted.

Restart xrpd...

/etc/init.d/xrdp restart

You should now be able to connect with your rdp client...

share|improve this answer

While they manage to fix Unity with xrdp, I'd suggest to use the gnome desktop, there's a step by step procedure described here:

http://c-nergy.be/blog/?p=3518

share|improve this answer
    
Yeah, I'm currently using that work around, but it's just frustrating that there is only one RDP server software. –  D4nC00per Dec 7 '12 at 17:35

Have a look at teamviewer.com. I'm just trying it after spending hours faffing around with guacamole and installing x11rdp-o-matic and getting nowhere. It's not the ubuntu-native solution, but if it works...?

share|improve this answer
    
Teamviewer's a good solution. I use it to support my family it's very nice and a simple solution that I would advise anyone to use if you want an easy install and use setup. –  D4nC00per Feb 1 '13 at 18:02
    
@siamii That's kind of unfair - RDP is a Windows thing, you would have similar issues getting a remote X11 session up on Windows. –  Alan B Jun 16 '13 at 8:31

protected by Community Feb 10 at 13:45

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.