Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was trying to perform the the fix found at this link

It requires you to delete certain files from the /opt/google/earth/free folder and then add some new ones that you download. I deleted the files but the links to download the new ones were unusable. I was using gksudo nautilus so trash was disabled meaning I could not restore the files I had deleted. I the tried to go to the Google Earth website and reinstall it. I downloaded the .deb but when I tried to install it it gav me an error message saying "cannot install ia32-libs" I tried installing this via terminal and it gave me an error message saying

chad@chad-Lenovo-G570:~$ sudo apt-get install ia32-libs

[sudo] password for chad:

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

The following information may help to resolve the situation:
The following packages have unmet dependencies: ia32-libs : Depends: ia32-libs-multiarch E: Unable to correct problems, you have held broken packages.

Now I am stuck without a functioning Google Earth. How can I fix this?

share|improve this question
It may not be anything you have done, you may be affected by this bug It might pay you to read through the comments as many of them have managed to solve the issue – Chris Carter Dec 16 '12 at 17:00

I'm going to skip bashing you for allowing some random clueless guy on a random website to tell you what files to delete from your machine. I think you already get the idea.

If you did not download ANY files from their website, chances are you haven't compromised your OS installation yet. Otherwise all bets are off and you should reinstall your machine, no exceptions if you want to be safe, that is.

Reinstall packages you broke by deleting their parts earlier

First of all - you need to reinstall the packages files from which you have deleted. You can do this by verifying your packages with debsums:

sudo debsums -c

It's going to take some time. This is its output after I've manually removed /usr/bin/zipnote that belonged to the zip package.

$ sudo debsums -c
debsums: no md5sums for libaudio2
debsums: missing file /usr/bin/zipnote (from zip package)

You can see the /usr/bin/zipnote as a missing file. You can also see /var/lib/nvidia-common/last_gfx_boot file which has a different checksum. You could choose to reinstall the relevant packages just to be safe. You can find out which package owns that file by running:

$ dpkg -S /var/lib/nvidia-common/last_gfx_boot
nvidia-common: /var/lib/nvidia-common/last_gfx_boot

Then after you get the list of packages that you need to reinstall run:

sudo apt-get install --reinstall package1 package2 packageN

Fix ia32-libs

First verify the state of this package. It can be removed but there can be some parts of it left. Run:

dpkg -l ia32-libs

if it's anything other than

un  ia32-libs       <none>               (no description available)


sudo dpkg --purge ia32-libs
sudo apt-get update
sudo apt-get upgrade #(optional but strongly recommended)
sudo apt-get install ia32-libs

And finally download and install Google Earth:

sudo dpkg -i google-earth-stable_current_amd64.deb
share|improve this answer
None of the packages shown after running 'sudo debsums -c' have to do with ia32-libs – chad Dec 14 '12 at 2:48
That point wasn't strictly about ia32-libs, there's a separate part on it later in my post. Have you found and reinstalled the other broken packages as found by debsums? – Marcin Kaminski Dec 14 '12 at 12:19
yes I followed all of your steps and when I reinstall google earth it gives me the same error – chad Dec 14 '12 at 22:06
Take a look at Chris Carter's comment underneath your question and see if this affects you. Also printing the output of apt-cache policy ia32-libs-multiarch and the contents of /etc/apt/sources.list and /etc/apt/sources.list.d would be helpful. – Marcin Kaminski Dec 18 '12 at 3:07
ia32-libs-multiarch:i386: Installed: (none) Candidate: 20090808ubuntu36 Version table: 20090808ubuntu36 0 500 quantal/universe i386 Packages – chad Dec 19 '12 at 23:30

Try reinstalling ia32-libs sudo apt-get purge ia32-libs then sudo apt-get install ia32-libs then try installing google earth again. If anymore packages have issues do that same for them. For future reference it usually isn't wise to do things like that with out saving the original files. Also you should probably use more discretion over things like this; the files they want you to download could easily have malware even if you trust the author/publisher I doubt they have reviewed the code.

share|improve this answer
Yes thank you I realize it was a stupid thing to do. ia32-libs is not installed in the first place so uninstalling it and reinstalling it is not an option – chad Dec 10 '12 at 0:18
Did you check to make sure; just because you didn't do it yourself doesn't mean it wasn't a dependency for some other program – David Dec 10 '12 at 3:30
Yes when I run the purge command it tells me that ia32-libs is not installed and therefore cannot be removed – chad Dec 10 '12 at 20:59
did you originally install via a repository or a deb file – David Dec 10 '12 at 22:35
a deb file i think but it was a long time ago – chad Dec 11 '12 at 22:34
up vote 0 down vote accepted

Ok i finally figured it out. I ran the commands

sudo add-apt-repository ppa:gnome3-team/gnome3

sudo apt-get update

sudo apt-get install libcanberra-gtk-module

sudo apt-get install ia32-libs

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.