Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

since my upgrade from 12.04 to 12.10 I can't mount my NFS shares anymore.

I have a QNAP NAS and one Ubuntu machine that was using NFS for mounting.

I've used the following lines in /etc/fstab

10.1.1.6:/b /nas/pictures nfs rw,hard,intr,bg,nfsvers=3 0 0
10.1.1.6:/Qmultimedia /nas/qmultimedia nfs rw,hard,intr,bg,nfsvers=3 0 0

this worked without hickups in the past including during suspend.

After the upgrade the NFS share didn't mount anymore. Manual mounting is not working as well.

$ sudo mount -vvv /nas/music/
mount: fstab path: "/etc/fstab"
mount: mtab path:  "/etc/mtab"
mount: lock path:  "/etc/mtab~"
mount: temp path:  "/etc/mtab.tmp"
mount: UID:        0
mount: eUID:       0
mount: spec:  "10.1.1.6:/m"
mount: node:  "/nas/music"
mount: types: "nfs"
mount: opts:  "rw,hard,intr,bg,nfsvers=3"
mount: external mount: argv[0] = "/sbin/mount.nfs"
mount: external mount: argv[1] = "10.1.1.6:/m"
mount: external mount: argv[2] = "/nas/music"
mount: external mount: argv[3] = "-v"
mount: external mount: argv[4] = "-o"
mount: external mount: argv[5] = "rw,hard,intr,bg,nfsvers=3"
mount.nfs: trying text-based options 'hard,intr,bg,nfsvers=3,addr=10.1.1.6'
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 10.1.1.6 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying 10.1.1.6 prog 100005 vers 3 prot UDP port 54543
mount.nfs: mount(2): Permission denied
mount.nfs: access denied by server while mounting 10.1.1.6:/m

$ sudo mount -vvv -t nfs 10.1.1.6:/Qmultimedia /nas/qmultimedia
mount: fstab path: "/etc/fstab"
mount: mtab path:  "/etc/mtab"
mount: lock path:  "/etc/mtab~"
mount: temp path:  "/etc/mtab.tmp"
mount: UID:        0
mount: eUID:       0
mount: spec:  "10.1.1.6:/Qmultimedia"
mount: node:  "/nas/qmultimedia"
mount: types: "nfs"
mount: opts:  "(null)"
mount: external mount: argv[0] = "/sbin/mount.nfs"
mount: external mount: argv[1] = "10.1.1.6:/Qmultimedia"
mount: external mount: argv[2] = "/nas/qmultimedia"
mount: external mount: argv[3] = "-v"
mount: external mount: argv[4] = "-o"
mount: external mount: argv[5] = "rw"
mount.nfs: timeout set for Sun Dec  2 15:15:47 2012
mount.nfs: trying text-based options 'vers=4,addr=10.1.1.6,clientaddr=10.1.1.21'
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options 'addr=10.1.1.6'
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 10.1.1.6 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying 10.1.1.6 prog 100005 vers 3 prot UDP port 54543
mount.nfs: mount(2): Permission denied
mount.nfs: access denied by server while mounting 10.1.1.6:/Qmultimedia

the folders I want to mount are listed as available

$ showmount -e 10.1.1.6
Export list for 10.1.1.6:
/v                      
/m                      
/home                   
/backup                 
/Qweb            
/Qmultimedia            
/Qdownload

UID and GID are the same...

I've checked the NFS exports on the NAS... they are fine

[/etc] # cat exports
"/share/HDA_DATA/Public" *(rw,async,no_root_squash,insecure) 
"/share/HDA_DATA/Qdownload" 10.1.1.*(rw,async,no_root_squash,insecure) 
"/share/HDA_DATA/Qmultimedia" 10.1.1.*(rw,async,no_root_squash,insecure) 
"/share/HDA_DATA/backup" 10.1.1.*(rw,async,no_root_squash,insecure) 
"/share/HDA_DATA/home" 10.1.1.*(rw,async,no_root_squash,insecure) 
"/share/HDA_DATA/m" 10.1.1.*(rw,async,no_root_squash,insecure) 
"/share/HDA_DATA/v" 10.1.1.*(rw,async,no_root_squash,insecure) 
[/etc] # exportfs 
/share/HDA_DATA/Qdownload
        10.1.1.*
/share/HDA_DATA/Qmultimedia
        10.1.1.*
/share/HDA_DATA/backup
        10.1.1.*
/share/HDA_DATA/home
        10.1.1.*
/share/HDA_DATA/m
        10.1.1.*
/share/HDA_DATA/v
        10.1.1.*

How can I fix or troubleshoot this further?

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.