Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install Keryx which requires python < 2.7

I want to be able to use this software and yet not uninstall the newer version of python from my system and mess up any other programs that might be using it.

How can I install the above in my current setup?

A similar question exists here but does not have a valid answer -

How can I downgrade Python or use many versions?

share|improve this question

1 Answer 1

You can easily install Python 2.6 from the archives:

sudo apt-get install python2.6

Note 1: The default Python version (/usr/bin/python) will remain Python 2.7. To use version 2.6 you will need to use /usr/bin/python2.6 explicitly.

Note 2: Generally speaking, it is safe to install more than a version of the same software as long as you use packages provided by your distribution. If you want to install a version of a software not provided by the distribution, be sure to install it to /usr/local, or better use some isolation mechanisms (e.g. virtual environments/machines).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.