Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a .mp4 movie (it's an .mp4 file, and the "video codec" is Xvid, and the "audio codec" is mp3) that I want to play, but when I try to open it in MPlayer, it says "The steam is encrypted and decryption is not supported." I tried to apply the answer from this question and this wiki page, but neither worked.

Any suggestions?

The file came from an [apparently] less than reputable site, which I guess I can't link to. :(

I've tried:

sudo apt-get install ubuntu-restricted-extras
sudo apt-get install libdvdread4
sudo /usr/share/doc/libdvdread4/install-css.sh
sudo apt-get install gstreamer0.10-ffmpeg
sudo apt-get install w64codecs
sudo apt-get update
share|improve this question
    
can xine or VLC play the file? –  Yanick Rochon Jan 21 '11 at 15:35
    
xine gives a similiar error message, and VLC plays a scrambled mess of random colors for 6 seconds. –  Andrew Jan 21 '11 at 15:43
    
Is ubuntu-restricted-extras installed? (update your question with everything you've tried as you continue to work on it) –  Jorge Castro Jan 21 '11 at 16:33
7  
+1 for posting a torrent link on a stack exchange site! lol –  Yanick Rochon Jan 21 '11 at 16:50
1  
Hi, I've had a similar experience. That file may be corrupt or not what it's "pretending" to be. Careful running that on Windows since the last time I encountered a similar video file that VLC, Mplayer, Totem, including WMP, couldnt' play, it was actually a malware of sorts. Yes, so much for downloading from sites with questionable repute. –  Marky Jun 2 '11 at 5:02

5 Answers 5

It's probably protected by DRM (Digital Rights Management). Quite a number of the songs and such are DRM protected if the origical source is from iTunes etc.

The answers given here possibly applies to you as well.

share|improve this answer

Try xine or VNC media players, My personal choice is xine because it uses very little resources. Both are in the repository. Edit, sorry, did not see comment above. Where did the file come from? Can you post a link to it? Is it a pay to view movie?

share|improve this answer
    
It's not exactly pay-to-view, and I don't think I can post a link to it. –  Andrew Jan 21 '11 at 17:06

I uses either VLC or SMPlayer, but you need to have all the correct codec, for your issue of the error messages, there are many threads around but perhaps you could scan thru each of those

http://www.google.com/search?client=ubuntu&channel=fs&q=mp4+video+The+stream+is+encrypted+and+decryption+is+not+supported.&ie=utf-8&oe=utf-8

share|improve this answer

My solution was to go to Tools > Preferences > Video, make sure Enable video and Window decorations were checked, then set the Output drop-down menu to X11 video output (XCB).

See this answer for more information.

share|improve this answer

First, make yourself root by typing sudo -s, press enter, and key in your password when prompted.

After this, type in sudo apt-get install vlc

VLC Player will play just about anything. If your MP3 files still do not work, you will need to download the restricted codecs pack. Search for these in Google and use the above command to install them once you find out what the file-name is. I.e., type in sudo apt-get install [filename].

DVD playback is the same as above, you will need the restricted repositories. Again, once you locate them, just type in the above.

EDIT: All of the above, and indeed many other countless codecs and programs can also be installed through the Synaptic Package Manager. To access this, click Systems > Administration > Synaptic Package Manager.

This can be a bit of a headache though, as there are many, many things available, and if you do not know the specific program name or keywords for it used through the search function, it can be difficult.

share|improve this answer
    
It's not necessary to start a root shell first, if you're going to run administration commands as root with sudo. You can skip sudo -s, and just use sudo apt-get install vlc. Please note that it's best to run sudo apt-get update first as this updates local information about what packages are available from where in what versions. This can prevent a variety of installation errors (including some "unmet dependencies" errors), and also ensures you get the latest version provided by your enabled software sources. –  Eliah Kagan Mar 21 '13 at 12:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.