Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

when I try doing a juju ssh into one of the machines, it returns an error

2012-12-06 14:16:16,695 INFO Connecting to environment...
2012-12-06 14:16:25,671 INFO Connected to environment.
2012-12-06 14:16:26,994 INFO Connecting to unit sqldb/0 at ec2-54-251-4-139.ap-southeast-1.compute.amazonaws.com

Permission denied (publickey).

I can still ssh into nodes I created a while back (2 months ago). I'm not sure what's happening. It seems juju is not copying over my public key to the new nodes I'm adding for some reason. Is it some sort of configuration issue?

share|improve this question
    
Juju, by default, uses your id_rsa.pub for the public key it copies. Do you still have a copy of this on your machine for your user in .ssh? –  Marco Ceppi Dec 6 '12 at 12:13
add comment

1 Answer

Yes. I do have this. On explicitly setting authorized key path to id_rsa.pub in the config file - it's working again. It was not picking the public id by default though.

Not sure why that was happening.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.