Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Is there a way to remove maximized window controls/title from top panel in Unity

I want to move my window controls (close, maximize, minimize) back to the current window while maximised. I removed global menu and indicator-appmenu already but the window controls still default to the panel (and hidden at that) when maximized.

Anyone got any ideas?

share|improve this question

marked as duplicate by Jorge Castro, fabricator4, Eric Carvalho, Ringtail, Luis Jan 6 '13 at 4:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

Ways to remove the global menu:

Some applications have extentions in order to support the global menu, maybe that is causing your problems. Is it happening to all applications or just specific ones? Which ones?

To disable Global Menu for Firefox, open Firefox, then select Tools – Add-ons –> Extensions and disable ‘Global Menu Bar integration’.

http://www.liberiangeek.net/2012/04/disable-the-global-menu-in-ubuntu-12-04-precise-pangolin/

Alternatively you can just remove the global menu extentions for firefox and thunderbird if you have that installed:

sudo apt-get remove firefox-globalmenu thunderbird-globalmenu
share|improve this answer
2  
As stated in the original post I have already done all of these items. I am still seeing the window control buttons on the unity panel when the window is maximized. I would like to change that behavior to having them on the running application regardless of window state. –  Gotsanity Dec 6 '12 at 14:31
    
I had the same problem in 12.10. I went back to 12.04 as I found it more stable and now I have the same issue. When any Application is maximized, the minimize,maximize, close button revert to the upper left hand corner. If not maximized then the buttons are in each open Application. What is strange is that this was not the way it was when I had 12.04 installed before. Was this the result of some update? I really dislike it. Any thoughts? –  chazdg Dec 26 '12 at 15:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.