Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have ubuntu 12.10 working on my system. I have tried many time to add repo but every time i tried i got the same error as in this case.

$ sudo add-apt-repository ppa:scopes-packagers/ppa
Cannot access PPA ( to get PPA information, please check your internet connection.

my net is working fine. apt-get install is also working.

so why is it giving error that check your internet connection? ( i am working under proxy server with authentication)

$ cat /etc/apt/apt.conf file

Acquire::http::proxy "http://username:password@";
Acquire::https::proxy "https://username:password@";
Acquire::ftp::proxy "ftp://username:password@";
Acquire::socks::proxy "socks://username:password@";
share|improve this question
up vote 1 down vote accepted

This problem was solved in a thread in the Ubuntu forums. Look here and scroll to the bottom.

share|improve this answer
thnx for your help. – RATHI Dec 6 '12 at 8:35
I feel a little bit stupid, but I don't really understand what I have to do in order to make it work... What should I write in "export https_proxy=...."? – user138784 Apr 9 '13 at 7:58

Only set http_proxy env variable is not enough. https_proxy is also required.

And I was needed to execute the add-apt-repository command as root, NOT via sudo. i don't know why it is not working with sudo but as root is working fine..

share|improve this answer
You can use sudo but need to provide the "-E" option, like "sudo -E add-apt-repository ..." to preserve the environment variables, otherwise, sudo start a clean session. – MV. Jul 19 '13 at 18:44

Use the "network" settings panel (System Settings->Network), click on "Network Proxy", and set the proxy server/port info for http & https, then click "Apply system wide"

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.