Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently upgraded my 12.04 LTS Ubuntu to 12.10 Ubuntu. During the installation process Third Party Resources were disabled. The dialogue suggested that "Some third party resources in your software.list were disabled.You can re-enable them after the upgrade with the 'software-properties' tool or your package manager.

Please guide how to enable third party sources? I don't find any interface were I can control enabling or disabling of third party sources.

Please note that I have Ubuntu Software Center and Update Manager installed.

Please also note that I had Redshift installed on my computer since 12.04 but the same is not working in 12.10.

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

To enable your third-party software sources:

  1. Open Ubuntu Software Centre.

  2. Go to Edit > Software Sources > Other Software

  3. Re-check all your sources that you want to be re-enabled.

Regarding Redshift:

I've had the same problem. It's not in the repositories.

Enter the below commands into the console to add the Redshift PPA for the Natty branch. Not exactly recommended, but it's been working for me for the last year.

echo "deb http://ppa.launchpad.net/jonls/redshift-ppa/ubuntu natty main" | sudo tee /etc/apt/sources.list.d/redshift.list
echo "deb-src http://ppa.launchpad.net/jonls/redshift-ppa/ubuntu natty main" | sudo tee -a /etc/apt/sources.list.d/redshift.list

You should now be able to install redshift from the terminal.

sudo apt-get install redshift
share|improve this answer
    
Thanks. I enables the third-party software sources succesfully. But still not able to run redshift. It shows that I have installed the latest redshift software. When I launch it, the icon appears for a couple of seconds and then disappears without any message or any action. –  Optimight Dec 6 '12 at 8:34
    
@Optimight: sounds like a separate question. Feel free to post another question. –  Flimm Dec 6 '12 at 9:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.