Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I copied a lot of files in my mounted Windows drive from Ubuntu and I subsequently ran into Error opening file '/media/windows/<some-file-path>': No space left on device error. I checked the output of df -i command to see if I had ran out of inodes for the mounted Windows drive:

Filesystem        Inodes   IUsed     IFree IUse% Mounted on
/dev/sda5        2363904  504119   1859785   22% /
udev              207621     522    207099    1% /dev
tmpfs             211487     450    211037    1% /run
none              211487       3    211484    1% /run/lock
none              211487       7    211480    1% /run/shm
none              211487      19    211468    1% /run/user
/dev/sda2      458686680 2588876 456097804    1% /media/windows

As above output shows, lots of inodes are available for /media/windows drive.

I have plenty of disk space left - around 500GB. What's the problem then?

share|improve this question
    
@MichaelHampton: No, I have not, in fact I have around 500GB of disk space left. –  abhinavkulkarni Dec 6 '12 at 4:22
    
You said the error was about inodes, but the message you gave says 'no space left on device'. Was there another error? –  belacq Dec 6 '12 at 4:45
    
@belacqua: This error happened when I was running a Java program to write files to /media/windows. I can still access the files, open them, etc. But I can't create new files. –  abhinavkulkarni Dec 6 '12 at 5:11
    
@belacqua: Yes, I mean I can't right-click and create a new file either. It's an Operating Systems error. –  abhinavkulkarni Dec 6 '12 at 5:16
    
It's suspicious that this is a windows directory. Why did you suspect inodes? –  belacq Dec 6 '12 at 5:17

1 Answer 1

Okay, problem solved. The Windows drive was corrupted and somehow was preventing Ubuntu to write any data to it. I ran the disk checker program at the start of Windows boot and everything works fine now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.