Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to apply the recommendation of question:

Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

After running that command: sudo mount --bind /dev /mnt/dev

I get this error message: mount: mount point /mnt/dev does not exist

fdisk -l returns

/dev/sda1
/dev/sda2
/dev/sda5

do I need to mount sda2 and sda5?

Edited after @psusi's comment:

/dev/sda1

is the boot file system

It seems that I need to mount sda2 or sda5. Here is what I tried: (I tried this on a virtual machine so the sda(s) are now vda(s) )

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/vda: 19.3 GB, 19327352832 bytes
16 heads, 63 sectors/track, 37449 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0008eece

   Device Boot      Start         End      Blocks   Id  System
/dev/vda1   *           3         496      248832   83  Linux
Partition 1 does not end on cylinder boundary.
/dev/vda2             498       37448    18622465    5  Extended
Partition 2 does not end on cylinder boundary.
/dev/vda5             498       37448    18622464   8e  Linux LVM
ubuntu@ubuntu:~$ 
ubuntu@ubuntu:~$ 
ubuntu@ubuntu:~$ sudo mount -t ext4 /dev/vda5 /mnt
mount: wrong fs type, bad option, bad superblock on /dev/vda5,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

ubuntu@ubuntu:~$ sudo mount -t ext2 /dev/vda5 /mnt
mount: wrong fs type, bad option, bad superblock on /dev/vda5,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

ubuntu@ubuntu:~$

Any info that can help me rescue that server would be greatly appreciated!

share|improve this question
1  
You need to mount whichever partition is your root filesystem in /mnt, like the linked question says. –  psusi Dec 6 '12 at 1:26
    
hi @psusi, thanks for your help, I mounted the boot filesystem instead of the root filesystem. Now I need to find out how to properly mount the root filesystem. I will edit the question. –  howaryoo Dec 6 '12 at 9:49
add comment

2 Answers 2

up vote 0 down vote accepted

It looks like /dev/vda5 is an LVM partition. Which work differently than block devices.

You might try this link:

http://linuxwave.blogspot.com/2007/11/mounting-lvm-disk-using-ubuntu-livecd.html

I haven't worked with LVM much, but that link looks promising.

share|improve this answer
    
thanks much @MCR pb solved. –  howaryoo Dec 6 '12 at 11:34
add comment

The error message is a consequence of a full /boot partition because of many kernel upgrades. One quick way to fix is to boot the system using the previous kernel version. (the SHIFT key brings up the grub menu during startup).

Once up and running the full /boot partition can be cleaned up for instance with:

http://ubuntugenius.wordpress.com/2011/01/08/ubuntu-cleanup-how-to-remove-all-unused-linux-kernel-headers-images-and-modules/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.