Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed Ubuntu 12.04 as a VMWare Virtual Machine. I like to switch between my Workspaces using the Ctrl+Alt+ArrowKeys but it doesn't work. It works on my other system with the "Proper" install.

This is a problem with only the Left and Right keys. It works fine for Up and Down.

share|improve this question
Are you using the left control key? – hexafraction Dec 5 '12 at 20:27
Yes. Tried the Right one as well. – Sheharyar Dec 6 '12 at 11:22
up vote 8 down vote accepted

Found it! It seems that VMWare uses the keys Ctrl+Alt+Left/Right, So there are two things you can do:

1. Change VMWare's Default keys - Go to VMWare > Edit > Preferences > Hot Keys and select some other combination

2. Change Ubuntu's Shortcut - Go to System Settings > Keyboard > Shortcuts > Navigation and select some other combination for Switch to Workspace Left/Right

share|improve this answer
According to the help text in the VMWare settings dialog, you can also use Ctrl-Alt-Space Ctrl-Alt-Left to send Ctrl-Alt-Left to the guest. – daniel kullmann Jul 1 '15 at 14:31

VM itself uses Ctrl+Alt for commands such as "Ctrl +_ Alt + Insert" is the same as Ctrl + Alt + Del" on your computer, you use the insert because that does the del command only in the VM where if you hit C+A+D it will bring you to the screen on your host comp not in the VM. so things like that may not work entirely running it in a VM.

Now that i read that it may be confusing so let me know if it is.

share|improve this answer
Hmmm... So it is because of VMWare. Thanks. Looking for a solution now... – Sheharyar Dec 6 '12 at 11:19

This question is old but today I was dealing with this same issue so my two cents here.What has worked in my case with VMWare Fusion 6 is:

  1. Open VMWare Fusion's Preferences (CMD+,)
  2. Select Keyboard & Mouse Tab
  3. Uncheck "Enable Mac OS Host Keyboard Shortcuts"

This way I have native shortcuts and if I require to use Mission Control I can accomplish that holding at the same time CTRL+CMD.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.