Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed KDE with the command sudo apt-get install kubuntu-desktop.

Now whenever I log into Unity I can see KDE-related services running in the background and I see no obvious way to prevent them from opening at startup. I checked bum but I see nothing there.

These are the services I see running right now:

kde4 klauncher knotify4

These ones I can identify as being related to KDE given their names, but there could be more.

How can I prevent these services from launching by themselves?

I should mention I often use KDE applications such as kate, okular and kile. Could these be responsible for opening those services?

share|improve this question
    
I have the same issue and I have uninstalled KDE so lets hope for an answer to this issue. Because it seems to me the start-up process is never cleaned, or isn't cleaned well enough. –  Goddard Dec 7 '12 at 20:09
add comment

3 Answers

You need to utilize "startup services" to disable those specific processes.

See this link for more information What's the recommended way to enable / disable services?

It gives you some options as "how to".

Go to System -> Preferences -> Startup Applications. Un-check things which you want to disable on startup.

share|improve this answer
    
No, this is not correct. Only a few services are shown here and the ones presumably left over from the KDE install do not show (nor do many others not related to KDE; this app is in fact quite simplistic and borderline useless for any need semi-advanced) –  Gabriel Dec 9 '12 at 21:32
    
Thank you for the link tough, it looks like it has some very useful info. –  Gabriel Dec 9 '12 at 21:33
add comment

Yes, KDE applications such as the ones you mentioned do require kde related processes to run. Unfortunately there is no way to stop these processes from running

share|improve this answer
add comment

You could try something like:

sudo update-rc.d -f insertnameofservice remove

See also How-To: Managing services with update-rc.d

share|improve this answer
    
This looks like the right direction. How do you see all of the services running or started? –  Goddard Dec 12 '12 at 3:02
    
Do you mean the services running right now? Alt+F2 and "gnome-system-monitor" or "htop" for the terminal list all running services. –  Christoph Stich Dec 15 '12 at 8:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.