Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently followed a guide to configure Samba but I couldn't get it configured properly. After realizing that the guide was six years out of date I thought I should start again.

I reinstalled samba by first using these commands:

sudo apt-get purge samba
sudo apt-get install samba

But after reading my configuration file (/etc/samba/smb.conf) I noticed that it was the same file, containing the same edits I had made. I then proceeded to delete the directory and then re-install samba again.

However, the directory is not replaced after re-instillation and now I don't appear to have a configuration file. How do I get it back? Or install Samba correctly?

share|improve this question
1  
Samba's configuration is managed by the package samba-common. Have you tried to purge and re-install that package? This might actually not work still, as the Debian/Ubuntu package maintainers of Samba decided to use ucf for configuration management. –  gertvdijk Dec 5 '12 at 15:34
    
@gertvdijk if you provide this as an answer then I can mark it as correct. –  Sheldon Dec 5 '12 at 16:16

2 Answers 2

up vote 3 down vote accepted

Yes, already posted in the comments as a verified solution, but posting as an answer anyway.

Purging should indeed remove the configuration files as well, yet the configuration of the Samba server is tracked by the package samba-common, not samba. Yes, it's a bit confusing.

So, try purging and re-installing both packages like this:

sudo apt-get purge samba samba-common
sudo apt-get install samba
share|improve this answer
    
I wonder if you can help me with this one as well. I'm trying to start samba but I get unknown service. I've tried sudo /etc/init.d/samba start, sudo service smbd start but that doesn't work. Also, the /etc/init.d/samba file doesn't seem to exist. –  Sheldon Dec 5 '12 at 16:33
    
There really is a file /etc/init.d/smbd in the package samba. See this. sudo service smbd restart should work. It's already started after install, so use restart. –  gertvdijk Dec 5 '12 at 16:38

If you only need the smb.conf configuration file, there is no need to reinstall samba. The default copy can be found in /usr/share/samba/smb.conf. The following will copy it to /etc/samba/, replacing the file you've been editing:

sudo cp /usr/share/samba/smb.conf /etc/samba/
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.