Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing the nvidia drivers from the additional drivers tab of software sources, running nvidia-xconfig and dpkg-reconfigure xorg xorg-server xorg-server-core, the system still boots into low graphics mode.

It can be fixed by a restart of lightdm but this shouldn't be necessary, any ideas?

thanks

share|improve this question
add comment

1 Answer 1

What worked for me on 12.10:

Make sure all three nvidia packages are installed:

sudo apt-get install nvidia-common nvidia-current nvidia-settings

(In case you want to be really sure; run install --reinstall). Also go for:

dkms status

to double-check that the required modules for your current kernel were built (it happened to me that I forgot to install the kernel headers after a kernel update; so dkms was not able to build the new modules automatically; leading to strange low resolutions on startup)

And you could run

sudo nvidia-xconfig

asking nvidia to create its own /etc/X11/xorg.conf.

share|improve this answer
    
This worked for me! Thanks! –  thameera Dec 9 '12 at 15:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.