Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Gembird cam68ut. On my Ubuntu 12.10 it shows black screen in cheese and guvcview. I tested it in win7, it works fine.

Here what I found:

  • It is a uvc compliant camera, I checked on the site: 18ec:3299 USB 2.0 PC Camera (model number QC3231) ArkMicro
  • This webcam is report by lsusb: Bus 001 Device 004: ID 18ec:3299 Arkmicro Technologies Inc.
  • Here is the output of dmesg | tail:

    uvcvideo: Found UVC 1.00 device USB2.0 PC CAMERA (18ec:3299)
    uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
    input: USB2.0 PC CAMERA as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-1.5:1.0/input/input17
    usbcore: registered new interface driver uvcvideo
    USB Video Class driver (1.1.1)
    
  • When I run cheese (or guvcview), here what I get in terminal:

    libv4l2: error turning on stream: No space left on device
    (cheese:11797): cheese-WARNING **: Internal data flow error.
    
  • I tried it on different usb slots with the same results
  • The Webcam's microphone works, I can record audio with it

Update: I tested it on other two machines with the same Ubuntu and it works without problems having the same dmseg | tail message.

Guys, may be it is a bug with USB controller driver in the kernel (because on that machine camera works in win7)?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I tested it on two other machines with the same Ubuntu and it worked out of the box. It is a long known bug with USB host controller. I reported it on launchpad: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1088395. Also I found a very similar bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1088395

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.