Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm attempting to perform a "normal" install on a USB3 SSD (I don't know if it is noteworthy, but I don't have a swap partition). The installation proceeds normally (I'm installing from a USB2 device I created using LiLi Boot, with a copy of Ubuntu 12.10 64bit that I downloaded directly from the source. The system I'm running Ubuntu on has had a more traditional installation of ubuntu running on it without issue (also 12.10), so I know that everything works A-OK when booting from a 7200RPM internal disk.

There are a number of oddities that I've noticed so far, including graphics corruption, but the first and most pressing issue is that Grub2 refuses to recognize the correct hd. From /boot/grub/grub.cfg:

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_msdos
insmod ext2
set root='hd1,msdos1'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd1,msdos1 --hint-efi=hd1,msdos1 --hint-baremetal=ahci1,msdos1  b58ee4f7-d41d-400a-b7b8-18bd1f0ae9d3
else
  search --no-floppy --fs-uuid --set=root b58ee4f7-d41d-400a-b7b8-18bd1f0ae9d3
fi
    font="/usr/share/grub/unicode.pf2"
fi

This is from a 100% fresh install of linux (first boot), which was installed while no hard drives were connected to the system, other than the USB2 LiLi drive. The system refuses to boot unless I change the hd1,msdos1 -> hd0,msdos1 in the grub menu at boot, when it is the only disk device connected to the PC.

What options are left for me to troubleshoot this issue? I've been racking my brains and taxing the internet trying to dig up something on this problem, but now I'd like to see if the Ubuntu community can rise to the challenge and help me fix this boot problem.

This is the second time I've attempted this particular setup. The first time, after days of wasted time, I managed to get it to boot every other boot - i.e. every even boot it would boot into Ubuntu like it was happy; every odd boot it would boot into the BusyBox or Grub prompt. At one point it complained that it couldn't find /dev/disk/by-uuid/[the disk], which I found most perplexing, since the disk was there and booted before and after the occurrence (with intervention).

Update

Attempting to boot without changing hd1 -> hd0 gave me an alert before dropping into BusyBox: ALERT! /dev/disk/by-uuid/[uid] does not exist. Dropping to a shell! Where is it getting hd1 from?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

You are experiencing bug 384633. By editing the disk number in the grub boot command (which you may do at the grub prompt) run

sudo update-grub

to fix the disk numbering.

share|improve this answer
    
I've run update-grub a number of times, but according to the bug report it matters if the disk numbering changed between the install and the first reboot - which is true in my case, since I installed off a USB drive I removed post-install. I'll re-install off of a disk tonight and see if it resolves the issue. –  JoBu1324 Dec 6 '12 at 20:22
    
Installing off of a DVD fixed the hd1 -> hd0 issue, so I'm accepting your answer since it pointed me to the bug report that fixed my problem, but I'm still dropping into BusyBox 1/2 the time. I've started a new question here –  JoBu1324 Dec 7 '12 at 4:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.