Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Overnight, my ubuntu installation (latest LTS version) has stopped working.

Apart from automatic updates, I never made any changes to the system. As of yesterday, the computer starts extremely slowly, eventually takes me to the GRUB screen, and after choosing the operating system, simply stops on a light purple screen. Recovery boot does not work.

Does anyone have any idea how to fix this?

Thanks

share|improve this question
    
This question may help you. –  Mahesh Dec 5 '12 at 15:56
add comment

1 Answer 1

Remove the power cable, open the case, touch a metal component to ensure you have no static charge in your body, and unseat and then reseat the memory modules and the graphics card (if it's not integrated into the motherboard) - you may have a case of thermal socket expansion. As the machine heats up in during use and then cools down after being turned off, the memory modules and graphics card tend to move ever so slightly in their slots. Over time the movement causes the component to lost its contact with the motherboard. Once the machine is booting again, choose the option to run a memtest from the boot screen.

Memtest : Memtest with Ubuntu 12.04 live CD

Thermal socket expansion (aka chip creep) : Wikipedia link

share|improve this answer
    
Hey, thanks. I have never done anything of that sort before - it's a bit of a scary notion, but it all fails, I will certainly try. Is chip creep likely to happen on a device that is barely a few months old? Also, I can see all my hard drive partitions and such from a live session, does that make a difference? –  H Hall Dec 5 '12 at 8:25
    
Hmm, if you can get as far as a live session then your hardware is okay. Chip creep should not happen on a newish device, only years later. When you say 'recovery boot does not work', please provide us with the exact message(s) shown on screen - take a pad and pen and write them down then post here for us. –  Clive van Hilten Dec 5 '12 at 12:01
    
For this occasion, I chose to backup my files, wipe the entire ubuntu install with gparted (leaving the space unallocated) and reinstalling from live USB. Probably not the most elegant solution, but the cleanest and, for me, the simplest, as I am not great with code and such. I just hope it won't happen again. HH –  H Hall Dec 5 '12 at 14:38
    
Cool, sometimes a clean install is just the fastest way. –  Clive van Hilten Dec 5 '12 at 17:56
    
Or not. It worked for 1 day. Now, I can not boot any more. Instead, I get the "unknown filesystem. Grub rescue" message. To make it worse, live session does not work, neither from CD, nor from USB. I have no idea what to do. Do you? –  H Hall Dec 6 '12 at 11:49
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.