Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the above functioning ok using the usb print server, however, I cannot get the drives to mount in the fstab. using 192.168.0.x net with dlink router. I can moount using the GUI in Gnome but I want the drive to mount automatically

share|improve this question
Please add what you've tried to mount the device as, and the output of dmesg so we can determine what the device shows up as – Jorge Castro Jan 21 '11 at 16:55

I have had a little NAS attached for music and film streaming for over a year with only the occasional problem generally because the NAS decided it needed a (sleep). The solution I found which has worked through 9.10 - 10.10 is detailed here.

Mounting Windows SMB File Shares Using Cifs

its a bit of an old post but it still works for me probably the most important part is adding the package smbfs as without this (which isn't installed by default) fstab wont be able to mount the shares.

Hope this helps

share|improve this answer
still does not work.....I will post setup files later – rangerruss Jan 23 '11 at 23:01
turned out the problem was with spaces in the share name....i forgot to enter a 0 before the 40....thanks for yuor responsed – rangerruss Jan 25 '11 at 3:24
no problem it's always the little things that catch you out like I normally forget to install smbfs and sit there scratching my head for a couple of hours thinking why its not working before a massive head slap. – Allan Jan 25 '11 at 9:58

For 11.10, my system found the GoFlex Home 3TB automatically after clicking "Browse Network" in the file manager. Seamless. (I don't know what AFP volumes are, but Ubuntu apparently does.)

Alternatively, I was also able to mount it as a CIFS drive by editing /etc/fstab, using general mount instructions on the net.

I'd only recommend this for people who are comfortable with manually editing their home network and using the terminal. Particular for this NAS, some key steps were:

1) Edit my router to always allocate the same IP number to the GoFlex (compared to the default where the number could change upon reboot--for safety, I also edited the GoFlex configuration to always request the same number).

2) To keep spaces in fstab from being confused as the mountpoint/type/options/etc, replace the device name GoFlex Home Personal to the character escaped Goflex\040Home\040Personal.


Write Speed: CIFS seems faster, but I'll admit I haven't tried every combination/option possible. Comparing the manual CIFS mount to the automatic AFP volumes, on my admittedly slow wired connection (on my generally slow machine, reading from an ntfs partition), music files wrote over cifs at 10MB/s and over AFP at 3MB/s.

Note: 3MB/s was a write to 'GoFlex Home Public' which can be accessed by my TV as a DLNA drive, so the GoFlex might be indexing or recognizing the files as media. If so, that could explain the delay. Transferring photos via AFP goes at 5MB/s.

share|improve this answer

I know it's different hardware but I recently bought a Netgear Stora which I had the same issues with, i.e. Netgear said it was compatible with Linux but really meant that I could access it with a browser.

I managed to get fstab configured to mount the drives during boot (your mileage may vary due to the different hardware).

I blogged about it here (mainly so that when I pave my system for 11.04 I'd not have to trawl the web again!) but the content is similar to Allans link (wish I'd seen that earlier in the week!)

Hope this helps :-)

share|improve this answer
Well....I retuned the GoFlex and purchased a Dlink 323 and have it up and running perfectly with linux.....both the printer server as well and disk access..... but thanks for your reply – rangerruss Feb 11 '11 at 16:45
I didn't notice that you had fixed your problem when I posted, thought you were still having problems - note to myself: read ALL comments first ;-) – DilbertDave Feb 12 '11 at 8:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.