Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Eee PC will allow me to turn on the computer to login page, but I cannot get the keypad or the touch pad mouse to move. I have turned it off, taken out the battery then restarted it and the same happens. Is there anything I can do to fix this?

Thanks for your time,

share|improve this question
2  
Is that something related to Ubuntu? –  mikewhatever Dec 5 '12 at 3:06
add comment

1 Answer 1

I was having the exact same problem with Ubuntu 12.10 on an Asus Eee pc 1225. I've had some trouble with ACPI functions with this machine in the past. I'm no longer buying Asus products because they are poorly made.

Anyways, to fix this problem I added a boot parameter to GRUB. I found the suggested solution here: Keyboard not working on a Samsung 300e5a laptop

I tried adding acpi=noirq but that seemed to only re-enable the keyboard. The touchpad still didn't work. Next I tried acpi=off. That worked to get both keyboard and touchpad working. I also tried acpi_iso=Linux and that also worked. I tried rebooting and not changing the boot parameters and the keyboard and touchpad again didn't work. It only worked with acpi_iso=Linux and acpi=off. Your results may be different.

To change the boot parameters, check this link: How do I add a kernel boot parameter?

Basically, when GRUB starts at boot, press E to bring up the editor. Find the line that starts with linux and add acpi_iso=Linux to the end of it, and then press Ctrl+X.

Then if that fixes your problem, make the changes permanent by editing the /etc/default/grub file. Find the GRUB_CMDLINE_LINUX_DEFAULT line and add acpi_iso=Linux to the end of the value on the right. Save, run sudo update-grub and reboot.

I hope that works out for you. Good luck.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.