Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Today I installed Ubuntu and since then i cannot boot into Windows anymore. I used the "standard" option (didnt change any partitions manually, just entered the size) but used the UEFI-mode.

At first the GRUB entries for Windows did not work at all, after reading this thead i was able to add a new Grub entry - now i can get into the "windows-loading" screen for a few seconds but then i always see some kind of bluescreen for a fraction of a second and the laptop reboots.

I can get into the windows recovery partition but the only option there is to reset everything to factory settings (+erase all data). I have no idea how to get into the Windows 7 repair mode which was mentioned here (tried everything else in this thread too - no success).

My boot info can be found here:

I have no idea what went wrong (there is even an extra page for the Zenbook Prime where no installation problems are mentioned).

I would appreciate any help/ideas, many thanks!


After further investigation and GRUB optimization (without final success) i think that the problem is most likely a corrupted Windows partition (or just the start sector? I CAN see/mount the windows partition from ubuntu).

Ubuntu works perfectly and Windows gets to the "Loading" screen (with the fixed GRUB entries) but crashes instantly afterwards (there is a bluescreen for a fraction of a second, afterwards the laptop reboots).

I tried several Windows recovery tools (Windows 7 Recovery disk etc.) but i cant get anything to load nor fix the problem - apparently Win7 recovery tools still have big problems with UEFI.

Does anyone have an idea how to fix or investigate a corrupted windows partition from Linux? As described i can see/edit the partition from ubuntu.

Thank you!

Update 2

For my Windows partition (/dev/sda3) GParted shows me a size of 86.2GB (with 72.36 used and 13.84 unused) while the mounted drive shows a size of 92.6 GB with 77.7 used and 14.9 unsused - could that be a reason for the corruption? Any idea how to fix this from Ubuntu (still couldnt get any Windows recovery tools to start from an USB stick..:)?


Final Update

The problem was in fact a corrupted start sector in Windows. After trying around for hours and manually creating an EFI-enabled Win7 USB stick (repair disk did NOT work, full disk was needed!) i was able to fix the bootsector.

Many thanks for your help!

share|improve this question
did you installed 32bit ubuntu or 64bit ubuntu? 32 bit ubuntu can't work with UEFI. or you may be hit by this bug. Please read this guide – Web-E Dec 5 '12 at 4:32
@Web-E: I installed 64bit and ubuntu is running fine - the Windows7 grub entry did not work but as described above i was able to fix this manually, however, Windows 7 does not load... – jpdus Dec 5 '12 at 10:58
up vote 1 down vote accepted

It's possible that your Windows installation has been damaged -- for instance, if you resized your Windows partition(s) when installing Ubuntu, the resize operation might have corrupted your data. (It sounds like you did not resize partitions, but that's not 100% clear, so I mention this as a possibility.) If the problem is in Windows, your best bets are:

  • Try the Windows recovery tool (boot from an emergency disc if necessary -- they are available legally for download, although I don't have any links handy).
  • Ask for help on a Windows forum.

OTOH, it's possible that there's a subtle problem with your boot loader configuration. I don't see anything obviously wrong in what you've posted, but it looks like something may have created backups of some of your Windows boot files. If Ubuntu did this during installation, it's conceivable that it's accidentally damaged some of those files. You should check out the various .efi files in what is, from Linux, /boot/efi/EFI/Microsoft/Boot. Check them against their like-named .bkp files. If the installer (or whatever created the .bkp files) did what seems logical, I'd expect these files to be identical. If the bootmgfw.efi file, in particular, is empty or seems damaged, that could be the problem.

Another comment along these lines: GRUB 2 can be weird sometimes, and configuring it manually can be tricky. Therefore, you might try using another boot manager instead of or in addition to GRUB 2. The easiest to install and configure is probably my rEFInd, but gummiboot is another possibility. To use rEFInd, you should be able to install it just by running its script from your Linux installation. When you reboot, you should see a boot menu with Windows and Ubuntu listed as options, and probably another for whatever's in the ESP's EFI/boot/bootx64.efi (most likely that's a duplicate of the Windows boot loader, but I can't be positive of that). If Windows works from rEFInd, then you can continue using rEFInd. If not, then rEFInd at least probably won't hurt, except to add a step to get to Linux. (You can easily uninstall rEFInd by removing the /boot/efi/EFI/refind directory; or you can reconfigure your system to boot Ubuntu directly from rEFInd, bypassing GRUB. See rEFInd's documentation on booting Linux for details.)

share|improve this answer
I did resize the Windows partition (via the automatic installer with the "slider" - didnt change anything manually), sorry for not making that clear. My "bootmgfw.efi" file is just 122.9kb (same size as "bootx64.efi) while the "bootmgfw.efi.bkp is 672.6kb - could that be a problem? Apart from that a corruption due to the repartitioning seems most likely to me now, i will try the Windows recovery tool. – jpdus Dec 5 '12 at 11:01
The bootmgfw.efi on my Windows 7 installation is 670,800 bytes in size, so a damaged or changed boot manager file is looking likely to me. You might try juggling them or referencing the bootmgfw.efi.bkp in your GRUB configuration. – Rod Smith Dec 5 '12 at 15:52
I tried to change this entry but this did not change anything (in fact i think the original bootmgfw.efi was just modified by boot-repair). Most likely the windows partition is somehow corrupted - any ideas how to fix it? Tried several Windows-Recovery Tools without success so far (seems like all available tools have problems with UEFI configurations). – jpdus Dec 6 '12 at 0:30
  1. Wait until all packages have a green check on this page:
  2. then boot into your installed Ubuntu, connect internet, open a terminal and type the following command: sudo apt-get update; sudo apt-get install -y boot-sav

  3. Then run Boot-Repair --> Recommended Repair. Write on a paper the new URL that will appear.

  4. Reboot the PC. The Windows UEFI entry in GRUB should now work. (if not, indicate the new URL)
share|improve this answer
The Windows UEFI entry in GRUB works already (after editing the GRUB entry manually or using Boot-Repair) - but windows crashes instantly. So most likely the main problem is not the bootloader but a corrupted windows partition - any ideas how to fix that from linux? Tried several windows recovery tools without success so far... but i will try your idea once the updated packages are online, thank you! – jpdus Dec 6 '12 at 0:41
ok, let me know! – LovinBuntu Dec 6 '12 at 10:07
This did not change anything - windows crashes instantly and i have no idea how to restore it ... – jpdus Dec 6 '12 at 13:04

I have the same problem on dell n5050 and on hp probook 4340s. Windows crashed during startup animation.

My solution: I run ubuntu from USB stick, and used disk utility to remove all linux partitions from the hard drive. Once linux was removed - windows is booting up again with no problems. I did not use any other boot repairing utils, I just removed linux partitions.

I think since ubuntu 12.04 there is something broken in partitioning utility, which makes windows freak out and crash. I hope someone will fix this soon.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.