Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do i change the boot splash background color to be black, not purple? I have edited /lib/plymouth/themes/default.grub to

if background_color 0,0,0 ; then clear fi

then I also changed these rows in /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.script as follows:

Window.SetBackgroundTopColor (0.0, 0.00, 0.0); # Nice colour on top of the screen fading to Window.SetBackgroundBottomColor (0.0, 0.00, 0.0); # an equally nice colour on the bottom

Then in configuration editor on apps/gnome-session/options/ i have set splash_image to /lib/plymouth/themes/ubuntu-logo/ubuntu_logo.png

The result is a bit weird... When I start the machine, a blank purple screen appears white it boots then the white ubuntu logo and the progress dots appear on a black screen for just a second or two before the login screen. Aren't they supposed to replace this purple screen in the whole boot process? When I shut down or reboot the machine, it is only as it is supposed to according to my settings, i.e. with black background, white ubuntu logo and progress dots. How to fix this? Any ideas? I don't like this purple background on every boot at all... :( This is on ubuntu 12.04.

share|improve this question
    
2-3 second before login screen is the real splash screen, if u dont want to see any purple while booting up, u should change grub2 background color to black (or another color) –  Nur May 2 '13 at 2:17

1 Answer 1

You haven't mentioned this in your question but I assume you ran

sudo update-initramfs –u

in the terminal after you made the changes.
If you didn't you need to, then reboot.

share|improve this answer
    
Yes. I ran it and rebooted lots of times since then. Now the purple is gone, it is black but the progress dots and logo appear for just for a few seconds before the logon sscreen. Maybe the key is not splash_image but splash image? –  svs Dec 9 '12 at 22:16
    
but " " (space) is invalid character, should be with "_" right? –  svs Dec 9 '12 at 22:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.