Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running ubuntu 12.04 on an IBM thinkpad t42. I just installed gnome and cinnamon but I am still using unity the only problem is that in dash when I search for any application they don't appear. I don't see recent applications either. I fixed it by running unity -- reset but the next time I turned on my computer it was broken again

share|improve this question

5 Answers 5

up vote 8 down vote accepted

Reinstall unity-lens-applications and unity-lens-files logged out and back in and it should work.

share|improve this answer
    
Worked for me too. –  Matt Joiner Jan 17 '13 at 2:44
    
Working - Affirmative! –  SGhosh Sep 21 '13 at 5:52
    
It was working. But it is not working after the reinstall. –  Asuraya Nov 15 '13 at 9:20

This worked for me:

  1. Switch to tty1 (Ctrl+Alt+F1) and login as myself.
  2. rm -rf ~/.compiz (in order to recursively delete session logs... there might also be ~/.compiz-1 and so on, delete them all!)
  3. sudo service lightdm restart
  4. login using the standard greeter again.

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/943083/comments/14

share|improve this answer

The Unity Dash shows applications which have .desktop shortcuts in /usr/share/applications/ or ~/.local/share/applications/. So ensure that the application has a .desktop shortcut in at least one of these two folders.

share|improve this answer
    
I have .desktop files in those locations but no applications show up until i run <code> unity -- reset </code> –  wil Dec 5 '12 at 0:14
    
could reinstalling unity also help –  wil Dec 5 '12 at 16:45
    
I tried putting <code> unity -- reset </code> into my start up but that didn't work because when unity resets the desktop environment break –  wil Dec 5 '12 at 17:56

Enter Ubuntu software center, search for unity > "More Info" and if you scroll down, there are "Optional addons". Check unity lens files and applications then apply.

share|improve this answer

Try:

sudo dpkg-reconfigure -A

It should be working.

share|improve this answer
1  
Can you please edit and improve your answer. What exactly does the given command do and does it improve/solve the OP's issue! –  v2r Jul 4 at 16:30
1  
this for unity dash for not showing installed application, that command will restore the configuration of dash to be to able see again all application installed. look at this my previews problem imgur.com/scnOTpv –  xsoultribex Jul 5 at 1:41
    
after try using that command, this it now imgur.com/scnOTpv –  xsoultribex Jul 5 at 1:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.