Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed 12.10 and noticed some strange behaviour every time I connect a USB storage device. It reports I already have the device mounted by a different user but there is only one user account on this set up.

Here is a picture of the dialogue: unable to mount

Also when I try to mount the inserted USB drive, I have to enter gain root privileges before the device will unmount successfully. Like this:

unable to unmount with without root access.

I can't copy/delete any file without root access either with the default file manager or third party file manager, Marlin.

How do I resolve this rather frustrating experience? Thanks in advance.

share|improve this question
add comment

2 Answers 2

First, as root just unmount the device. If there is a problem in the mount table this might clear it up.

As for mounting a USB, any type of mount command for devices generally requires root priv. Once that happens, depending on the underlying permission of the USB filesystem, you still might have problems accessing it unless you are root.

share|improve this answer
    
It didn't help when I unmounted with as root. It seems I can't do anything else without root with every usb drive I have tried out. What's wrong –  Mysterio Dec 4 '12 at 23:09
add comment

If the drive is formatted ntfs then you need to install ntfs-3g and ntfsprogs

sudo apt-get update && sudo apt-get upgrade && sudo apt-get install ntfs-3g ntfsprogs;

It seems to be removed from the default install of ubuntu since 12.04LTS

share|improve this answer
    
It didn't work as I still have to gain root privileges for basic usb functions –  Mysterio Jan 14 '13 at 21:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.