Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Reliance broadband + mobile broadband connection. It connects fine, but the only problem is it takes more than 2 -3 mins to get the connection started. If I plug in the USB datacard, the network manager applet dothes not show up the mobile broadband connection immediately. It takes a good 2-3 mins to detect the connection before I can select Reliance connection from the dropdown list. Is there any way of getting a shortcut of that connection on the desktop or on the panel?

Thanks, Sayantan

share|improve this question
    
Does the Network Manager search for networks so long or detects and configures the hardware? –  ulidtko Jan 21 '11 at 7:11
    
the network manager takes time to detect the hardware i believe. this is because all wireless networks are detected in an around my home. –  Ubuntuser Jan 22 '11 at 21:10
    
@Ubuntuser: if you still have the issue please take a look at this answer: askubuntu.com/questions/48378/…. –  Guandalino Jul 6 '11 at 7:38

6 Answers 6

It takes time to boot for your modem too, don't forget. If it connects automatically its as fast as it gets (probably). Set up automatic connection. removing pin helped me since i'm not afraid to lose modem.

share|improve this answer

You can create "connections" in Network Manager (right click on its icon, Edit Connections) which would allow quick access to some connections you will likely be repeatedly using.

share|improve this answer
    
yes, to speed up, sometimes i do that, but i think, ubuntu takes time to detect the hardware. the mobile broadband option does not show up unless the usb is detected. –  Ubuntuser Jan 22 '11 at 21:12
    
moreover that is a lengthy way. as i said earlier, i was looking for a connection shortcut, just like we have in windows. –  Ubuntuser Jan 22 '11 at 21:17

As from your question i can understand that you are asking for a faster way to start up the internet. Does data card's active light is on immediately when plugged into the computer.If yes then there might be a bug in the data card's software.Report the problem to ISP, they might correct by providing an update.If no, there might a problem problem with your hardware.It might be your usb port or data card etc.Try plugging the data card in other usb port.

share|improve this answer
1  
the light is on immediately and it keeps on blinking green. i have tried other usb ports, all ports yield the same result. all i want is a shortcut on the desktop to connect manually instead of waiting for the network manager to load it up automatically. I am sure this is a problem with Ubuntu as this does not happen with Windows 7 that is installed in my other partition. –  Ubuntuser Jan 22 '11 at 21:16

With mobile broadband there is also the possibilty that network aquisition is simply slow the time to start up and fully negotiate a 3G cellular data connection can range from as little as a few seconds to several minutes depending on a range of factors. Signal strength and quality is often a big one as is interference, you can often get an idea of signal strength from the device itself or a mobile phone using the same network though that says less for quality.

Have you a mobile phone on the same network if so try taking the phone removing it's battery and cold starting it to get it to completely lock onto the network from scratch as soon as it loads hit the web browser and see how long it is before you manage to load a major website. Count the time from pressing the power button to the page load as in general terms mobile phones have hardware to handle the network side that will be setting up while the software is still booting too.

If you have a poort signal this could be a fact of life the connections for mobile broadband can take longer than phones also sometimes as the latter are often deliberately run at lower data rates etc than the full mobile broadband data service by for example not using all the channels leaving less to test for usability in the connection negotiation.

If however all looks good for siganal and using a mobile phone to do it then the problem is likely the USB modem or perhaps the USIM contact your ISP they should be able in most cases to provide a new sim for free and if it is under 12 months old the modem too most likely. Trying another USB port might help preferably on a different hub (generally the front ports on a computer are a different root USB hub in hardware to the rear so swap them over. That will only apply however if the problem appears to be slow detection of the hardware not a connection matter.

share|improve this answer

If as you say this works well in windows 7 I would make sure that windows 7 connection information was copied to the Linux connection manager. This may or may not include dns servers or domains, security types and network ID

share|improve this answer
    
No it wont help. For windows reliance has a separate software to dial in. And moreover,it is the hardware which does not get detected instantly, nothing wrong with the connection settings. –  Ubuntuser Mar 23 '11 at 21:15

On the network connections, edit your mobile broadband connection. On it have you ticked on the check box to connect automatically on the top? If not, check this box. That should fix the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.