Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to move my WUBI installation according to this: Move WUBI installation of Ubuntu to a different partition in Windows. But when I boot Ubuntu, it can't find the root.disk file. Is there any way to restore it? I have Ubuntu 12.10. Please help.

share|improve this question
Did you actually try to boot the new, temporary Wubi installation you created in step 5 from the question you posted? And are you sure you didn't change anything compared to the situation before? (exact filename, location, disk size, etc.) – gertvdijk Dec 4 '12 at 20:29

Do you have a copy of the original root.disk in a safe place? If not restore the original file from Windows backup and keep in a safe place.

  1. Uninstall Ubuntu from control panel.
  2. Reboot.
  3. Reinstall using WUBI using exactly the same specifications as the original.
  4. Reboot to Ubuntu and check that Ubuntu boots correctly.
  5. Reboot to Windows and copy the original from the safe place to the boot location, such as C:\Ubuntu\Disks.
  6. Reboot to Ubuntu.

One more step

See for details (Thanks to bcbc for pointing out this part.) The following is taken from that answer:

Assuming Ubuntu is being moved from D: to C: and if D: is /dev/sda2 and C: is /dev/sda1, then you'd hit 'e' on the first entry of the grub menu and change:

set root=(hd0,2) becomes set root=(hd0,1)

Delete the line - search --no-floppy xxx (as this overrides the previous set root command using the old UUID)

linux /boot/vmlinuz-xxxx root=/dev/sda2 ... becomes linux /boot/vmlinuz-xxx root=/dev/sda1 ...

This is a one-time override - hit Ctrl+X to boot, and make sure you run sudo update-grub after booting to fix the grub.cfg menu so it works the next time.

PS: There may be some variations. (hd0,2) could be (hd0, msdos2) or (/dev/sda, msdos2) depending on the version of Grub. Also root=/dev/sda2 may be root=UUID=xxxxx

Hope this helps

share|improve this answer
I tried that, but my disk file seems to be damaged. :( – Anonymous Dec 4 '12 at 22:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.